Bug 1400416 - RFE: Advise to take backup of IPA server before uninstalling IPA server
Summary: RFE: Advise to take backup of IPA server before uninstalling IPA server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-01 07:17 UTC by Abhijeet Kasurde
Modified: 2017-08-01 09:44 UTC (History)
4 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Abhijeet Kasurde 2016-12-01 07:17:25 UTC
Description of problem:
As an administrator, I would love to have an option which will ask me to take backup of IPA server before uninstallation (as uninstallation is NON-REVERSIBLE). I agree, I can take a backup before uninstalling but not necessarily remember to take backup before uninstall.

Version-Release number of selected component (if applicable):
ipa-serer-4.4.0-14.el7_3.x86_64


How reproducible:
100%


Actual results:
No user prompt to take backup before uninstallation.

Expected results:
User prompt to take backup before uninstallation.

Comment 2 Petr Vobornik 2016-12-09 17:27:01 UTC
Per triage on Dec 6, IPA currently has similar warning in interactive mode. But it doesn't mention ipa-backup utility. This warning will be adjusted to mention it.

The new options won't be implemented.

Comment 3 Petr Vobornik 2016-12-09 17:29:26 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6548

Comment 4 Martin Babinsky 2017-01-18 08:42:43 UTC
As agreed, the warning message in the uninstaller was re-written to mention ipa-backup.

Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/ae2d0a221772267ecda30896dc8897a3f4b4a97b

Comment 6 Abhijeet Kasurde 2017-05-22 11:12:48 UTC
# ipa-server-install --uninstall

This is a NON REVERSIBLE operation and will delete all data and configuration!
It is highly recommended to take a backup of existing data and configuration using ipa-backup utility before proceeding.

IPA Version verified with :: ipa-server-4.5.0-13.el7.x86_64

Marking BZ as verified.

Comment 7 Martin Kosek 2017-05-26 09:39:44 UTC
Please note that Red Hat officially released public RHEL-7.4 Beta this week, as announced here:
https://www.redhat.com/en/about/blog/red-hat-enterprise-linux-74-beta-now-available

The new RHEL-7.4 release includes a lot of new IdM functionality, including this RFE. Highlights can be found in RHEL-7.4 Release Notes, especially in the Authentication & Interoperability chapter:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7-Beta/html/7.4_Release_Notes/new_features_authentication_and_interoperability.html

IdM Engineering team would like to encourage everyone interested in this new functionality (and especially customers or community members requesting it) to try Beta and provide us with your feedback!

Comment 8 errata-xmlrpc 2017-08-01 09:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.