Bug 140043 - Time Zone wrong setting
Time Zone wrong setting
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 09:19 EST by nowayout
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 09:56:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nowayout 2004-11-19 09:19:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Hello

I am from cyprus. In Date & Time if you go to regional settings in the
map near greece and turkey their is an island called cyprus. You have
our town located in Asia/Nicosia. Cyprus is in Europe now. I think you
should fix this :)

Europe/Nicosia

Thanx
Charalambous Glafkos

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Change Asia/Nicosia to Europe/Nicosia

Additional info:
Comment 1 Nils Philippsen 2004-11-19 09:51:36 EST
This list comes from /usr/share/zoneinfo/zone.tab which references
Asia/Nicosia but not Europe/Nicosia. Changing the component. The
relevant version here is tzdata-2004e-2.
Comment 2 Jakub Jelinek 2004-11-19 09:56:55 EST
Please argue about this with tz@elsie.nci.nih.gov which is the only place
where this can be changed.  Fedora tzdata package will get that change as soon
as it makes upstream.
Comment 3 Jakub Jelinek 2004-11-19 09:59:35 EST
Actually, there is Europe/Nicosia too:

The source has:

# Classically, Cyprus belongs to Asia; e.g. see Herodotus, Histories, I.72.
# However, for various reasons many users expect to find it under Europe.
Link    Asia/Nicosia    Europe/Nicosia
Comment 4 Nils Philippsen 2004-11-19 10:14:32 EST
Unfortunately I can't use that info in s-c-date because it doesn't
make it into /usr/share/zoneinfo/zone.tab...
Comment 5 Jakub Jelinek 2004-11-19 10:22:17 EST
Which is why that should be discussed with upstream.
But I think it is better if the reporter argues with upstream than myself,
as I'd have to act only as middle-man, I don't know enough from history
about this.  The sole fact that Cyprus is now in EU doesn't change anything
on whether Cyprus is in Europe or Asia, if Turkey ever makes it into EU, it
will still be (mostly) in Asia.
Comment 6 nowayout 2004-11-19 17:09:43 EST
hm.. noo Turkey is in Asia. Cyprus was all the time Greece. The 
Language spoken is also greek. If Turkey comes in EU it will be in 
Asia but not Cyprus. Cyprus is Greek. It is just wrong from the start 
for cyprus to be in Asia. It have to be Europe/Cyprus like other 
Countries.
Comment 7 Jakub Jelinek 2004-11-19 17:16:35 EST
Just mail upstream and explain them your arguments then.
Comment 8 nowayout 2004-11-20 04:07:18 EST
I don't know what is upstream and how to contact them and what do I
have to tell them exactly?
Comment 9 Nils Philippsen 2004-11-23 10:32:50 EST
"Upstream" means the source of the original package, the tarball containing the
sources for the package. Jakub, who are the upstream people here? I could only
find an FTP URL in the spec file.
Comment 10 Jakub Jelinek 2004-11-23 10:52:02 EST
See comment #2. Upstream for tzdata is tz@elsie.nci.nih.gov mailing list.

Note You need to log in before you can comment on or make changes to this bug.