Bug 140050 - Convert queries to current locale
Summary: Convert queries to current locale
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-19 14:57 UTC by Michael Schröder
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 23:55:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Locale patch (5.56 KB, patch)
2004-11-19 14:59 UTC, Michael Schröder
no flags Details | Diff

Description Michael Schröder 2004-11-19 14:57:59 UTC
The attached patch makes rpm convert query output to the current 
locale.

Comment 1 Michael Schröder 2004-11-19 14:59:50 UTC
Created attachment 107057 [details]
Locale patch

Comment 2 Jeff Johnson 2004-11-19 23:05:04 UTC
The looks like an approach to the problem, once over seems
correct as well.

The real problem, that rpm string types are 8 bit clean but
not utf8 encoded, needs to be addressed in *.spec parsing
during build, and perhaps a utility that runs periodically
against the rpmdb, converting changelog entries once, not
every query, in package headers.

The real fixx needs to go after string types, not just changelog,
as well, as the day of i18n package names and file names in rpm
packaging is rapidly approaching.

Comment 3 Jeff Johnson 2005-10-26 23:55:13 UTC
Patch added to rpm-4.4.3-0.25.


Note You need to log in before you can comment on or make changes to this bug.