Bug 140062 - tg3 reports incorrect information to mii-tool
tg3 reports incorrect information to mii-tool
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-tools (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 11:06 EST by Brian Long
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 10:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Long 2004-11-19 11:06:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
mii-tool does not return the correct value when querying the Broadcom
BCM5701-based PCI Gigabit 1000Base-SX card.  It appears the tg3 driver
needs to fix mii-tool support or remove mii-tool support since ethtool
reports the correct value.  mii-tool reports 10BaseT while ethtool
reports 1000Mbps.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1. Install HP Gigabit NIC:
Ethernet controller: Broadcom Corporation NetXtreme BCM5701 Gigabit
Ethernet (rev 15)
Subsystem: Compaq Computer Corporation NC6770 Gigabit Server Adapter
(PCI-X, 1000-SX)
2. mii-tool eth2
3. ethtool eth2
    

Actual Results:
mii-tool returns:
eth0: 10 Mbit, half duplex, link ok

ethtool returns:
Settings for eth0:
        Supported ports: [ FIBRE ]
        Supported link modes:   1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes

Expected Results:
mii-tool should return:
1000Mbit, full duplex, link ok

Additional info:
This happens on kernel 2.4.21-9.ELsmp and 2.4.21-20.ELsmp.
Comment 1 David Miller 2004-11-23 15:18:32 EST
When a fibre interface is present, we return -EOPNOTSUPP for
the ioctls that mii-tool uses.

If mii-tool isn't handling that error condition correctly,
then that is what needs to be fixed.
Comment 2 Brian Long 2004-11-29 07:41:47 EST
How can I verify mii-tool is the culprit?  Should this bug get
assigned to the mii-tool developer?
Comment 3 John W. Linville 2004-11-30 13:58:56 EST
Assigning to owner of net-tools package for appropriate action...
Comment 4 Radek Vokal 2004-12-01 02:54:27 EST
mii-tool is obsolete and doesn't know about gigabit NICs. So I suggest
using ethtool while ethtool is heading to fully substitute mii-tool.
(new version of net-tools in fc3 has a note in mii-tool(8) about this)
Comment 5 Brian Long 2004-12-03 08:40:30 EST
If mii-tool were to echo "This program does not return proper
information from Gigabit adapters; please use ethtool", that would be
acceptable.  Currently, mii-tool is broken on RHEL 3 because it
returns bogus information.  If it returned an error message when
querying Gigabit adapters, that would be fine; returning bogus
information saying 10mbs is a bug and I believe it should be fixed.
Comment 6 Brian Long 2005-10-06 10:20:20 EDT
Red Hat support / prod mgmt claims mii-tool will not be fixed.  Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.