Bug 1400643 - sssd prevents sudo from getting data from LDAP
Summary: sssd prevents sudo from getting data from LDAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.9
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-01 17:08 UTC by Dalibor Pospíšil
Modified: 2020-05-02 18:34 UTC (History)
7 users (show)

Fixed In Version: sssd-1.13.3-53.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1399589
Environment:
Last Closed: 2017-03-21 09:58:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 4290 0 None None None 2020-05-02 18:34:26 UTC
Red Hat Product Errata RHBA-2017:0632 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2017-03-21 12:30:13 UTC

Description Dalibor Pospíšil 2016-12-01 17:08:21 UTC
+++ This bug was initially created as a clone of Bug #1399589 +++

The same applies to rhel-6

Description of problem:
Apparently sssd prevents sudo from getting some options from LDAP, at least 'defaults !requiretty'.
This is regression as it worked with sssd-1.12.4-47.el6_7.7

Version-Release number of selected component (if applicable):
sssd-1.13.3-48.el6

How reproducible:
100%

Steps to Reproduce:
1. use linked test
2.
3.

Actual results:
phase dedicated to sssd fail

Expected results:
whole test passes

Comment 2 Jakub Hrozek 2016-12-05 14:19:38 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3257

Comment 3 Jakub Hrozek 2016-12-08 16:03:56 UTC
master: 46703740e83a66909974a5ee8d47df6a6e5076e7
sssd-1-14: 76e97affaa05ce45709efd59d120595c5992aa21
sssd-1-13: 4e25db79aa514e044449c8ad4482c45b24e7a3d4

Comment 4 Jakub Hrozek 2016-12-08 16:04:31 UTC
Please qa_ack this bug if you're able to verify it during the 6.9 cycle

Comment 9 errata-xmlrpc 2017-03-21 09:58:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0632.html


Note You need to log in before you can comment on or make changes to this bug.