Bug 1400915 - provide method to remove binary string keys from rbd_children omap
Summary: provide method to remove binary string keys from rbd_children omap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.1
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 2.2
Assignee: Jason Dillaman
QA Contact: Hemanth Kumar
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1412948
TreeView+ depends on / blocked
 
Reported: 2016-12-02 09:56 UTC by Harald Klein
Modified: 2017-07-30 15:30 UTC (History)
4 users (show)

Fixed In Version: RHEL: ceph-10.2.5-7.el7cp Ubuntu: ceph_10.2.5-3redhat1xenial
Doc Type: Enhancement
Doc Text:
.The rados utility now supports the --omap-key-file option With this update, the `rados` command-line utility supports the `--omap-key-file` option. You can use this option to specify the path to a file containing the binary key for `omap` key-values pairs. The following commands take `--omap-key-file`: * `getomapval` * `setomapval` * `rmomapkey`
Clone Of:
Environment:
Last Closed: 2017-03-14 15:47:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC
Ceph Project Bug Tracker 18123 None None None 2016-12-02 13:59:19 UTC
Red Hat Knowledge Base (Solution) 2790641 None None None 2016-12-02 09:59:20 UTC

Description Harald Klein 2016-12-02 09:56:59 UTC
Description of problem:

Need a way to remove a key/value pair from the rbd_children omap by specifying the binary string key (containing 0 characters). This is required to clean up a stale reference caused by https://bugzilla.redhat.com/1400884

Version-Release number of selected component (if applicable):

2.1

How reproducible:

n/a

Actual results:

binary strings can't be specified in "rados rmomapkey"

Expected results:

add a method to remove a binary string key

Comment 1 Jason Dillaman 2016-12-06 00:08:29 UTC
Upstream, master branch PR: https://github.com/ceph/ceph/pull/12286

Comment 7 Hemanth Kumar 2017-02-07 10:51:37 UTC
Verified the cli command and it working as expected..

Comment 12 errata-xmlrpc 2017-03-14 15:47:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.