Bug 1400977 - Wrong symlink causes failure to start Wildfly out-of-the-box
Summary: Wrong symlink causes failure to start Wildfly out-of-the-box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wildfly
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gil cattaneo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1425069 (view as bug list)
Depends On: 1404261
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-02 13:26 UTC by Benjamin Lefoul
Modified: 2017-06-09 19:11 UTC (History)
8 users (show)

Fixed In Version: wildfly-10.1.0-10.fc25 wildfly-10.1.0-10.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 00:02:51 UTC
Type: Bug


Attachments (Terms of Use)
not "extension", trivial (1.23 KB, patch)
2016-12-21 09:52 UTC, Benjamin Lefoul
no flags Details | Diff

Description Benjamin Lefoul 2016-12-02 13:26:24 UTC
On a fresh F25 server, install and start Wildfly 10:

dnf install -y @javaenterprise hibernate-entitymanager hibernate-envers hibernate-java8 hibernate-infinispan jbossws-cxf glassfish-jaxb-jxc slf4j-ext slf4j-jboss-logmanager

systemctl start wildfly

It fails to start out-of-the-box because of a wrong symlink:

org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'wildfly-clustering-singleton-api-10.1.0.Final.jar' at path 'wildfly-clustering-singleton-api-10.1.0.Final.jar' (position: END_TAG seen ...ce-root path="wildfly-clustering-singleton-api-10.1.0.Final.jar"/>... @28:82) caused by: java.io.FileNotFoundException: /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/singleton/main/wildfly-clustering-singleton-api-10.1.0.Final.jar (No such file or directory)

This symlink:

/usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/singleton/main/wildfly-clustering-singleton-10.1.0.Final.jar -> /usr/share/java/wildfly/wildfly-clustering-singleton.jar

...should infact be:

/usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/singleton/main/wildfly-clustering-singleton-api-10.1.0.Final.jar -> /usr/share/java/wildfly/wildfly-clustering-singleton-api.jar

Probably the name "singleton" is used instead of singleton-api somewhere in the spec file?

Comment 1 Fedora Admin XMLRPC Client 2016-12-02 14:41:27 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Update System 2016-12-02 18:06:10 UTC
wildfly-10.1.0-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2ebc525db8

Comment 3 Fedora Update System 2016-12-03 04:38:08 UTC
wildfly-10.1.0-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2ebc525db8

Comment 4 Benjamin Lefoul 2016-12-07 11:27:15 UTC
By the way is there a reason why these are not "requires" and need manual install:

hibernate-entitymanager
hibernate-envers
hibernate-java8
hibernate-infinispan
jbossws-cxf
glassfish-jaxb-jxc
slf4j-ext
slf4j-jboss-logmanager

?

Comment 5 gil cattaneo 2016-12-07 11:51:48 UTC
(In reply to Benjamin Lefoul from comment #4)
> By the way is there a reason why these are not "requires" and need manual
> install:
> 
> hibernate-entitymanager
> hibernate-envers
> hibernate-java8
> hibernate-infinispan
> jbossws-cxf
> glassfish-jaxb-jxc
> slf4j-ext
> slf4j-jboss-logmanager
> 
> ?

The "Requires" list is automatically generated by our java "tools".
I have not been able to verify the installation, as did some,
from "zero" of wildfly. Usually I use dnf upgrade ...
I have launched a new build (rawhide):
http://koji.fedoraproject.org/koji/taskinfo?taskID=16786086

thanks for the tip

Comment 6 Fedora Update System 2016-12-11 00:29:23 UTC
wildfly-10.1.0-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Benjamin Lefoul 2016-12-21 09:52:09 UTC
Created attachment 1234280 [details]
not "extension", trivial

Mmh, actually it's org/wildfly/clustering…, not org/wildfly/extension/clustering… (wildfly-clustering-singleton-api ≠ wildfly-clustering-singleton-extension).

Patch attached.

Comment 8 gil cattaneo 2016-12-21 10:56:07 UTC
(In reply to Benjamin Lefoul from comment #7)
> Created attachment 1234280 [details]
> not "extension", trivial
> 
> Mmh, actually it's org/wildfly/clustering…, not
> org/wildfly/extension/clustering… (wildfly-clustering-singleton-api ≠
> wildfly-clustering-singleton-extension).
> 


maybe this could help:

modules/system/layers/base/org/wildfly/clustering/api/main/module.xml
    <resources>
        <artifact name="${org.wildfly:wildfly-clustering-api}"/>
    </resources>

modules/system/layers/base/org/wildfly/clustering/singleton/main/module.xml
    <resources>
        <artifact name="${org.wildfly:wildfly-clustering-singleton-api}"/>
    </resources>

modules/system/layers/base/org/wildfly/extension/clustering/singleton/main/module.xml
    <resources>
        <artifact name="${org.wildfly:wildfly-clustering-singleton-extension}"/>
    </resources>

Comment 9 Benjamin Lefoul 2016-12-21 12:54:34 UTC
The RPM creates the symlink at:

/usr/share/wildfly/modules/system/layers/base/org/wildfly/extension/clustering/singleton/main/wildfly-clustering-singleton-api-10.1.0.Final.jar

and nothing in:

modules/system/layers/base/org/wildfly/clustering/singleton/main


see attachment

Comment 10 Benjamin Lefoul 2017-01-17 07:46:55 UTC
Can we have this corrected in F25?

Comment 11 gil cattaneo 2017-02-20 14:19:28 UTC
*** Bug 1425069 has been marked as a duplicate of this bug. ***

Comment 12 Danny Stieben 2017-03-22 20:05:14 UTC
This issue still has not yet been fixed. Any updates on getting this pushed into the repos?

Comment 13 aaraodeo 2017-04-25 21:46:10 UTC
Its yet not fixed in wildfly-10.1.0-7.fc25.

Comment 14 Benjamin Lefoul 2017-04-26 06:00:52 UTC
I don't even think it is fixed in wildfly-10.1.0-9.fc26.
I think it is a simple fix (see comment 9).

Symlink is currently in:
/usr/share/wildfly/modules/system/layers/base/org/wildfly/extension/clustering/singleton/main

...instead of:
/usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/singleton/main

Gil, can you update?

Comment 15 Benjamin Lefoul 2017-04-26 06:35:59 UTC
(I just noticed Gil is tagged "on vacation", I don't know until when.)

Comment 16 gil cattaneo 2017-04-26 09:38:40 UTC
I cant work for fix this issue (and other) because latest F25 update break my system and my pc become unusable. i sent an email @ Fedora Developement list [1], but until now I did not get support to understand the problem

[1] https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/TWTHAKK6B5RBI5L6RQ2S543KHCGH4GHJ/

Comment 17 Benjamin Lefoul 2017-05-08 14:55:23 UTC
What about rawhide?

Comment 18 Jan Pazdziora 2017-05-16 08:14:55 UTC
(In reply to gil cattaneo from comment #16)
> I cant work for fix this issue (and other) because latest F25 update break
> my system and my pc become unusable.

The problem can be easily reproduced in virtual machines as well, so you can boot any other OS on your PC and just run Fedora in the VM.

Comment 19 gil cattaneo 2017-05-16 14:03:43 UTC
(In reply to Jan Pazdziora from comment #18)
> (In reply to gil cattaneo from comment #16)
> > I cant work for fix this issue (and other) because latest F25 update break
> > my system and my pc become unusable.
> 
> The problem can be easily reproduced in virtual machines as well, so you can
If i can not use a "normal" approach i do not care.
Also a new installation of Fedora25 x64 become unusable on my pc, cause, Ananconda crash, or my pc freeze, or other weird stuff. Also tried with korora25 x64 (... from bad to worse ...).
> boot any other OS on your PC and just run Fedora in the VM.
I do not have any other OS. And I'm not interested in purchasing them

Comment 20 Fedora Update System 2017-05-24 11:52:30 UTC
wildfly-10.1.0-10.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6aa6a0e83b

Comment 21 Fedora Update System 2017-05-24 17:00:48 UTC
wildfly-10.1.0-10.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2293ac2bbe

Comment 22 Fedora Update System 2017-05-25 19:21:17 UTC
wildfly-10.1.0-10.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6aa6a0e83b

Comment 23 Trevor Flynn 2017-05-25 21:44:51 UTC
Hello,
I have done several clean installs and can replicate easily. I have applied the above patches, but have discovered a 404 on port 9990 for the admin console which may or may not be related. I also have noticed that I am getting an error in the log. 

[org.jboss.msc.service.fail] (MSC service thread 1-2) MSC000001: Failed to start service jboss.infinispan.hibernate: org.jboss.msc.service.StartException in service jboss.infinispan.hibernate: Failed to start service
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1904)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:748)
Caused by: org.infinispan.commons.CacheException: Unable to load component metadata in file hibernate-infinispan-component-metadata.dat
        at org.infinispan.factories.components.ComponentMetadataRepo.initialize(ComponentMetadataRepo.java:119)
        at org.infinispan.factories.GlobalComponentRegistry.<init>(GlobalComponentRegistry.java:106)
        at org.infinispan.manager.DefaultCacheManager.<init>(DefaultCacheManager.java:225)
        at org.jboss.as.clustering.infinispan.subsystem.CacheContainerBuilder.start(CacheContainerBuilder.java:108)
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948)
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881)
        ... 3 more
Caused by: java.lang.NullPointerException
        at org.infinispan.factories.components.ComponentMetadataRepo.readMetadata(ComponentMetadataRepo.java:33)
        at org.infinispan.factories.components.ComponentMetadataRepo.initialize(ComponentMetadataRepo.java:117)
        ... 8 more


Thanks,
Trevor

Comment 24 Fedora Update System 2017-05-26 06:03:13 UTC
wildfly-10.1.0-10.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2293ac2bbe

Comment 25 Trevor Flynn 2017-05-26 17:41:21 UTC
I can confirm that on a clean install of wildfly-10.1.0-10.fc25 from the testing repo, the issue with the symlink and dependencies appears to be fixed. Tested on a fully updated VM of F25: 4.10.17-200.fc25.x86_64.

The admin console still has a 404 and must be a different issue all together. 

Thanks,
Trevor

Comment 26 Fedora Update System 2017-06-05 00:02:51 UTC
wildfly-10.1.0-10.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2017-06-09 19:11:10 UTC
wildfly-10.1.0-10.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.