Bug 140118 - cups upgrade produces raw postcript
cups upgrade produces raw postcript
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 15:49 EST by james
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.117-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 05:55:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2004-11-19 15:49:24 EST
From Bugzilla Helper:
User-Agent: Opera/7.54 (X11; Linux i686; U)  [en]

Description of problem:
After upgrading cups, printing fails, with raw stairstepped 
postscript code printed instead of the rendered print image.

1) The /etc/cups/ppd/<printer>.ppd file is recreated with the wrong 
file permissions - not world readable.  I suspect the file is 
generated with invalid assumptions about root's umask.  BAD!

2) The /var/log/cups/error_log file fails to say anything about a 
read permission error.  ALSO BAD!


Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8 and foomatic-3.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. upgrade cups
2. have non-root user print postscript document
3.
    

Actual Results:  raw postscript code prints

Expected Results:  rendered postscript prints

Additional info:

1) Either
a) the ppd file should have the permissions set explicitly, or
b) the ppd file permissions should be set to the original value, or
c) whatever parses the ppd file should have appropriate uid or gid.

2) The error_log file shows

 D [19/Nov/2004:10:49:39 -0700] [Job 40] foomatic-rip version 
$Revision: 3.43.2.6 $ running...
 D [19/Nov/2004:10:49:39 -0700] [Job 40] Parsing PPD file ...

followed by
 a) nothing - if the ppd cannot be read because of a permission error
or
 b) D [19/Nov/2004:13:15:42 -0700] [Job 45] *cupsFilter: 
"application/vnd.qcups-postscript 0 foomatic-rip"
 - if the ppd file can be read.

The error_log file should show the permission error! since this is 
hard enough to find by itself.  Also, it is not obvious that the ppd 
_has_ to have world read permission since, hey, maybe the print stuff 
can read files owned by root.  NOT - oops.
Comment 1 Tim Waugh 2004-11-22 09:46:34 EST
Those files are created by system-config-printer.
Comment 2 Tim Waugh 2004-11-23 11:54:20 EST
Fixed in CVS.
Comment 3 Tim Waugh 2004-11-24 05:55:50 EST
Fixed package is 0.6.117-1, although that package depends on the rawhide python
package.

Please re-open if you think this is important enough to warrant an update
package for FC3.

Note You need to log in before you can comment on or make changes to this bug.