Bug 1401220 - swapon fails for swapfile 4G or bigger
Summary: swapon fails for swapfile 4G or bigger
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 25
Hardware: ppc64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-12-03 16:14 UTC by Stuart D Gathman
Modified: 2017-02-21 13:57 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-21 13:57:47 UTC


Attachments (Terms of Use)

Description Stuart D Gathman 2016-12-03 16:14:01 UTC
Description of problem:
swapon: /var/cache/swap/swap.dat: swapon failed: Invalid argument

Version-Release number of selected component (if applicable):
util-linux-2.28.2-1.fc25.ppc64
kernel-core-4.8.6-300.fc25.ppc64

How reproducible:
Always

Steps to Reproduce:
1. dd if=/dev/zero of=swap.dat bs=1024  count=4194316
2. mkswap swap.dat
3. sync # long standing bug requires swap header on disk before kernel sees it
4. swapon swap.dat

Actual results:
swapon: /var/cache/swap/swap.dat: swapon failed: Invalid argument

Expected results:
Successful completion

Additional info:
A swapfile 1K shorter than 4G works.  As a workaround, swapspace can be increased beyond 4G by using multiple swapfiles.

Comment 1 Dan Horák 2016-12-09 17:15:37 UTC
I can't reproduce this issue within the same environment (kernel, util-linux) on a physical machine. AFAIK Stuart was using a KVM guest.

Comment 2 Stuart D Gathman 2016-12-09 20:13:00 UTC
(In reply to Dan Horák from comment #1)
> I can't reproduce this issue within the same environment (kernel,
> util-linux) on a physical machine. AFAIK Stuart was using a KVM guest.

Yes, I was using a KVM guest to debug an issue with cjdns building for ppc64.  Let me test on x86_64 KVM guest...

Comment 3 Stuart D Gathman 2016-12-09 21:43:47 UTC
Works in a F25 KVM on X86_64.  I'll ask to borrow a ppc64 vm again to see if it is still broken there.  Or are you already doing that?

Comment 4 Ngo Than 2016-12-14 10:47:41 UTC
i have tested on F25 KVM on ppc64, it works fine for me.

following packages is installed in kvm ppc64:
kernel-4.8.4-301.fc25.ppc64
util-linux-2.28.2-1.fc25.ppc64

i'm testing it again with new kernel-4.8.10-300.fc25.ppc64, will post the result soon

Comment 5 Karel Zak 2017-02-21 13:57:47 UTC
I guess, we can close this issue. 

[Please, reopen if able to reproduce with the new updates]


Note You need to log in before you can comment on or make changes to this bug.