Bug 140150 - dell 700m / intel 855 integrated video card freeze every other boot
dell 700m / intel 855 integrated video card freeze every other boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-20 03:21 EST by michael mastrangelo
Modified: 2013-03-05 22:42 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 13:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michael mastrangelo 2004-11-20 03:21:28 EST
Description of problem:
It freezes every other time I turn on my computer.

Version-Release number of selected component (if applicable):


How reproducible:
Get the Dell 700m Laptop. It comes with the intel 855 integrated 
video card.

Steps to Reproduce:
1. Install FC3 (in fedora core 2 this was not a problem - also heard 
that if you upgrade from FC2 to FC3 this is not a problem - only on 
fresh install)
2. Since it does not let you pick which video card you have in the 
install it picks 852.
3. Other things to try: Let it remain 852. In KDE pick 855 as the 
video card. In xorg.conf change 852 to 855.
  
Actual results:
Every other restart it says i have new hardware. If i pick configure 
it switches my xorg.conf into the default one with 852 that the first 
was there when I installed Fedora Core 2/3. 
But no matter what I pick (configure/ignore/do nothing) it just goes 
and past the boot up (if i have /etc/inittab as 3 it shows the login 
screen, if i have /etc/inittab as 5 it shows a grey screen with a 
timer cursor) and freezes. Then I have to preform a hard reboot. On 
the next boot it will ask if i want to check the hard drive and then 
not notice any new hard ware and then boot correctly. Then the next 
boot we are back to the begining.

Expected results:
It should have detected 855 to begin with. It should not freeze every 
other boot. It should allow me to have 852 or 855 in xorg.conf 
without any problems. 


Additional info:
Since it freezes every other boot even if /etc/inittab is 3 i do not 
understand how the video card has anything to do with it. But then 
again I do not know why it asks me if i ignore/configure/do nothing 
every other boot also.
Comment 1 michael mastrangelo 2004-11-23 00:57:43 EST
so i guess it was a problem with:

/etc/rc.d/rc5.d/S02haldaemon

changing to this fixes the problem:
/etc/rc.d/rc5.d/K02haldaemon

please dont include version .2 software on "stable" versions of your os
Comment 2 Mike A. Harris 2004-11-23 04:26:52 EST
>2. Since it does not let you pick which video card you have in the 
>install it picks 852.

Makes no difference.  There is one single Intel driver for Intel
integrated video, the "i810" driver.  If you manually chose
the card you have instead of letting it autodetect, the config
file would still use the "i810" driver.  The text printed out
by "lspci", "scanpci", the X server log file, and added to the
config file in "Vendorname", "Boardname" and the like is 100%
cosmetic, for human eyes only and has no effect at all on the
driver's operation.

In other words, if it said "Intel perjpowejraioejr;ewrjiaserawer"
it would still use the i810 driver, and still have whatever
problem you were experiencing.  A side effect of this, is that
if our hardware PCI ID to device name mapping is incorrect
for your video device, while we could change it to be correct,
and we do make such corrections when they're reported to us,
that would only correct the problem of cosmetic display of the
hardware's part number.  Again, the driver does it's own
internal detection and knows correctly that the chip is an i855
if it really is one.  If you read the X server log file (please
attach it using bugzilla file attachment below" the video
driver will indicate the correct video chipset.  I believe
Intel might use the same PCI ID for the i852 and i855 perhaps
(just a hunch), which if correct, is just another cosmetic
and harmless issue from a driver standpoint.

If disabling the hal daemon resolves the issue, then there is
still a problem present to be tracked, and it could be hal itself,
or it could still be the video driver.  More investigation would
be needed to be conclusive, however since you've indicated the
problem goes away when disabling haldaemon, and I'm not familiar
with what haldaemon pokes around with, I'm reopening this and
reassigning it to hal component, as other users may likely
experience the problem.

Either way, it'd be nice to fix the issue for you.  ;o)

Thanks for the report.
3. Other things to try: Let it remain 852. In KDE pick 855 as the 
video card. In xorg.conf change 852 to 855.
Comment 3 David Zeuthen 2004-11-23 09:52:13 EST
> so i guess it was a problem with:
> 
> /etc/rc.d/rc5.d/S02haldaemon
> 
> changing to this fixes the problem:
> /etc/rc.d/rc5.d/K02haldaemon

I'm puzzled where this comes from. On my box it's called S98haldaemon
and that's also how it looks in both FC3 and FC-devel. Michael, any
idea what you did to your system?
Comment 4 Matt 2004-11-23 12:27:28 EST
I told michael to stop the process from being initialized in 
runlevels 3/5, after singling it out in an interactive boot on my own 
700m.  He probably just saw the other K02 symlinks and grabbed that, 
as opposed to changing it to K98 (no difference, seeing as it's not 
started in those runlevels yet anyway.)  I'm sure this was just a 
typo, the problem still exists.  I'd attach a verbose output from 
running it as --no-daemon, but I dont have the laptop with me at the 
moment;  I assume that will be the required next step, as well as 
trying the latest CVS.
Comment 5 David Zeuthen 2005-01-17 15:28:11 EST
I think that I've got a fix for this one; please try the packages here

 http://people.redhat.com/davidz/hal-cvs20050117/

Cheers,
David
Comment 6 David Zeuthen 2005-01-17 15:31:33 EST
Note that you will need a 2.6.10 kernel from either Rawhide or FC3
updates. Thanks.
Comment 7 David Zeuthen 2005-01-20 13:51:53 EST
So, I've got someone on the hal mailing list to test this

 http://lists.freedesktop.org/archives/hal/2005-January/001686.html

I believe this is exactly the same issue so I'm closing this bug,
since this is fixed in hal-0.4.6 which will be in Rawhide and FC3
updates soon. Feel free to reopen if it doesn't work for you.

Note You need to log in before you can comment on or make changes to this bug.