Bug 1401534 - fuse mount point not accessible
Summary: fuse mount point not accessible
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 3.8
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rjoseph
QA Contact:
URL:
Whiteboard:
Depends On: 1385605 1386626
Blocks: 1388323
TreeView+ depends on / blocked
 
Reported: 2016-12-05 14:14 UTC by rjoseph
Modified: 2017-01-16 12:26 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1386626
Environment:
Last Closed: 2017-01-16 12:26:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-12-05 14:16:22 UTC
REVIEW: http://review.gluster.org/16025 (rpc: fix for race between rpc and protocol/client) posted (#1) for review on release-3.8 by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Worker Ant 2016-12-20 17:12:28 UTC
COMMIT: http://review.gluster.org/16025 committed in release-3.8 by Raghavendra Talur (rtalur@redhat.com) 
------
commit eda85ee122a58231c9b82224cb154d2e394d284a
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Sat Dec 3 01:10:51 2016 +0530

    rpc: fix for race between rpc and protocol/client
    
    It is possible that the notification thread which notifies
    protocol/client layer about the disconnection is put to sleep
    and meanwhile, a fuse thread or a timer thread initiates and
    completes reconnection to the brick. The notification thread
    is then woken up and protocol/client layer updates its flags
    to indicate that network is disconnected. No reconnection is
    initiated because reconnection is rpc-lib layer's responsibility
    and its flags indicate that connection is connected.
    
    Fix: Serialize connect and disconnect notify
    
    > Credit: Raghavendra Talur <rtalur@redhat.com>
    > Reviewed-on: http://review.gluster.org/15916
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    (cherry picked from commit aa22f24f5db7659387704998ae01520708869873)
    
    Change-Id: I8ff5d1a3283b47f5c26848a42016a40bc34ffc1d
    BUG: 1401534
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/16025
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>

Comment 3 Worker Ant 2016-12-21 23:22:29 UTC
REVIEW: http://review.gluster.org/16265 (rpc: fix for race between rpc and protocol/client) posted (#1) for review on release-3.8-fb by Kevin Vigor (kvigor@fb.com)

Comment 4 Niels de Vos 2017-01-16 12:26:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.8, please open a new bug report.

glusterfs-3.8.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-January/000064.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.