Bug 140167 - PHP depends on compat-db
Summary: PHP depends on compat-db
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-20 14:37 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 5.0.2-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 15:11:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
php-5.0.2-db4.patch (1.54 KB, patch)
2004-11-20 14:38 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2004-11-20 14:37:34 UTC
Description of problem:
PHP currently depends on compat-db, which shouldn't be the case. 
This problem is caused by the auto* files in PHP, which aren't able 
to handle db-4.3 for now.

Version-Release number of selected component (if applicable):
php-5.0.2-7

How reproducible:
Everytime, see below.

$ rpm -e --test compat-db
error: Failed dependencies:
        libdb-4.2.so is needed by (installed) php-5.0.2-7.i386
$

Actual results:
PHP depends on compat-db.

Expected results:
PHP should only require the current db4 version and no compat stuff.

Additional info:
My attached patch solves the issue for me. Maybe this patch also 
should be sent to upstream, if it isn't already merged there in 
CVS...

Comment 1 Robert Scheck 2004-11-20 14:38:08 UTC
Created attachment 107115 [details]
php-5.0.2-db4.patch

Comment 2 Robert Scheck 2004-11-23 15:11:26 UTC
Thank you for applying the patch to php-5.0.2-8, closing now.


Note You need to log in before you can comment on or make changes to this bug.