Bug 140168 - Please add gpgme 1.0.x to the distribution
Please add gpgme 1.0.x to the distribution
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-11-20 10:04 EST by Toshio Kuratomi
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-21 23:47:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Toshio Kuratomi 2004-11-20 10:04:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
gpgme, a library to make adding gpg support to an application easier
has  made a stable, 1.0, release as of September.  Including this
package in Core would allow software developers on Fedora to easily
port their software to the gpgme API so they can be built on Core with
gpg support.

Note that not all programs using gpgme have been ported to the stable
release.  Some are still using 0.3.x.  However, having gpgme 1.0.x
will allow those packages which have moved forward to use its features
for encryption while the others will have no loss of functionality and
it will make it easier for them to upgrade.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Notice that there's no gpgme package in FC3.

Additional info:

1.0.1 is the current release:

Fedora.us has packages for gpgme 0.4.
Comment 1 Bill Nottingham 2004-11-21 23:47:08 EST
Currently, there are two apps that have gpgme support, and they both
require different versions. Until there's something that actually uses
it, I doubt it will be in Core - Extras is a better place.
Comment 2 Toshio Kuratomi 2004-11-22 08:06:58 EST
Sure thing.  What're the two apps (Sylpheed and Balsa?) I'll spend
some time seeing if I can push some patches upstream to get them
running with the stable gpgme.  Then I'll revisit with two apps that
use it :-)
Comment 3 Bill Nottingham 2004-11-22 11:08:47 EST
sylpheed, balsa, and kmail, I think.
Comment 4 Toshio Kuratomi 2004-11-24 17:22:47 EST
Balsa tested - it seems to compile and run with gpgme 1.0.1.  I can
submit my patch to the spec if this is to go in.

kmail untested - grepping the sources and reading ChangeLog and
configure.in indicated kmail should be compatible with gpgme-1.0.1 but
trying to build it swapped my machine to death.  I guess I just don't
have the RAM to compile kdepim.  Rex Dieter has been building kmail
with gpgme-0.4.x, though.  I can ask him if gpgme-1.0.1 worked out of
the box as well or if there was anything that he had to do if it makes
any difference.

sylpheed - This needs work to get running with 1.0.1 as it has been
built to work with 0.3 instead of 0.4.  I'll get working on this but
don't know when it'll get in upstream as sylpheed is concentrating on
a 1.0 release right now.

My explorations also show that Rex is building the Fedora.us packages
with support for gpgsm (S/Mime) which requires having (at least parts
of) gnupg2.  For what I want (API for access to GPG keyrings, signing,
and verification) I disabled this in my private gpgme build.  If gpgme
is included, RH would have to decide how they want to deal with this.

(Note: The gpgme 1.0.x API is mostly an extension of 0.4.x  The
0.3->0.4 transition is where most breakage occurred.)

Note You need to log in before you can comment on or make changes to this bug.