Bug 1401918 (CVE-2016-9811) - CVE-2016-9811 gstreamer: Out of bounds heap read in windows_icon_typefind
Summary: CVE-2016-9811 gstreamer: Out of bounds heap read in windows_icon_typefind
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-9811
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1401951 1401952 1401949 1401950
Blocks: 1401937 1415638
TreeView+ depends on / blocked
 
Reported: 2016-12-06 12:04 UTC by Adam Mariš
Modified: 2019-09-29 14:01 UTC (History)
26 users (show)

Fixed In Version: gstreamer1-plugins-base 1.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-23 07:57:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:2060 normal SHIPPED_LIVE Moderate: GStreamer security, bug fix, and enhancement update 2017-08-01 19:34:49 UTC

Description Adam Mariš 2016-12-06 12:04:48 UTC
An out-of-bounds heap read was found in windows_icon_typefind.

Upstream bug:

https://bugzilla.gnome.org/show_bug.cgi?id=774902

Upstream patch:

https://github.com/GStreamer/gst-plugins-base/commit/2fdccfd64fc609e44e9c4b8eed5bfdc0ab9c9095

CVE assignment:

http://seclists.org/oss-sec/2016/q4/589

Comment 1 Adam Mariš 2016-12-06 12:42:19 UTC
Created gstreamer1-plugins-base tracking bugs for this issue:

Affects: fedora-all [bug 1401950]

Comment 2 Adam Mariš 2016-12-06 12:42:39 UTC
Created mingw-gstreamer1-plugins-base tracking bugs for this issue:

Affects: fedora-all [bug 1401952]

Comment 3 Adam Mariš 2016-12-06 12:42:54 UTC
Created mingw-gstreamer-plugins-base tracking bugs for this issue:

Affects: fedora-all [bug 1401951]

Comment 4 Adam Mariš 2016-12-06 12:43:10 UTC
Created gstreamer-plugins-base tracking bugs for this issue:

Affects: fedora-all [bug 1401949]

Comment 7 errata-xmlrpc 2017-08-01 22:28:08 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2017:2060 https://access.redhat.com/errata/RHSA-2017:2060


Note You need to log in before you can comment on or make changes to this bug.