Bug 1401998 - APM Mustang intermittent connectivity issues on eth0 using 4.8.x
Summary: APM Mustang intermittent connectivity issues on eth0 using 4.8.x
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2016-12-06 14:40 UTC by Paul Whalen
Modified: 2019-01-09 12:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-25 14:38:22 UTC


Attachments (Terms of Use)
dmesg (34.68 KB, text/plain)
2016-12-06 14:40 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2016-12-06 14:40:52 UTC
Created attachment 1228536 [details]
dmesg

Description of problem:

The APM mustang loses connectivity periodically, at times failing to bring up the eth0 interface at all. This has been an intermittent issue but seems to be worse with 4.8.8. 

Version-Release number of selected component (if applicable):

kernel 4.8.x


How reproducible:
Intermittent. 


Output from dmesg(full log attached):

[    8.084719] libphy: APM X-Gene MDIO bus: probed
[    8.361378] xgene-enet 17020000.ethernet (unnamed net_device) (uninitialized): Could not connect to PHY
[    8.371131] libphy: APM X-Gene MDIO bus: probed

[   15.925309] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[   15.930961] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.931371] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.938293] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   15.938695] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   15.945172] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[   15.945571] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[   15.952340] IPv6: ADDRCONF(NETDEV_UP): eth3: link is not ready
[   15.952723] IPv6: ADDRCONF(NETDEV_UP): eth3: link is not ready

Comment 1 Laura Abbott 2017-01-17 01:18:06 UTC
*********** MASS BUG UPDATE **************
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.
 
Fedora 25 has now been rebased to 4.9.3-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.
 
If you experience different issues, please open a new bug report for those.

Comment 2 Paul Whalen 2017-04-25 14:38:22 UTC
This is no longer an issue with later kernels. Closing.


Note You need to log in before you can comment on or make changes to this bug.