Bug 140210 - Adaptec 7899 won't work with fc3
Adaptec 7899 won't work with fc3
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-20 23:01 EST by George Mrvos
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-02 20:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description George Mrvos 2004-11-20 23:01:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
The install just hangs when trying to install the driver for adaptec
scsi support. Tries to install 7XXX driver and it just hangs forever

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start install
2.Graphical install

Actual Results:  system hangs

Expected Results:  install proceed

Additional info:
Comment 1 Need Real Name 2004-12-07 18:28:55 EST
This happens to me also under x86_64. When running the installation
procedure, after /sbin/loader starts, the system tries to load the
aic7xxx driver. After about 20 seconds I see the message:

Kernel panic - not syncing: Waiting List traversal

This happens every time, and has occurred on every machine with
an Adaptec SCSI controller that I have tried to load FC3 onto.
I have tried suggestions by others that I use 'aic7xxx=no_reset'
or 'aic7xxx=no_probe', but neither of these fixes worked.
Comment 2 David Allen 2005-04-11 15:25:46 EDT
Same problem for me with Tyan Thunder K7 2462 mobo with 7899 controller.
Apparently the kernel/driver/whatever is taking a _very_ long time to scan the
SCSI controller. After 25 minutes, the install will continue as normal. See bug
Comment 3 Dr. Amihai Silverman 2005-05-16 08:23:43 EDT
Same a problem while I try to install redhat enterprise WS
version 4 on an IBM Intellistation 6850-25G which have Aic7899 Controller.
At the first stage of the installation, it searches the aic7xxx driver and hangs
Typing on ALT-F4 I see that it finds the correct Adaptec AIC-7899 scsi
I also tryed to boot with noprobe, but than choosing the aic7xxx driver, it got
Is it possible to get the scsi driver image so I will load it from a disk ?
Dr. Amihai Silverman
Computer Center
Comment 4 Dave Jones 2005-07-15 15:35:26 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Dave Jones 2005-10-02 20:14:45 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.