Bug 140220 - Bugzilla will not let me add myself as a CC to a bug (v 2.18rc3)
Bugzilla will not let me add myself as a CC to a bug (v 2.18rc3)
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 03:56 EST by Reuben Farrelly
Modified: 2007-04-18 13:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 13:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-11-21 03:56:26 EST
When attempting to add myself to the CC list for a bug, I get this message
appear in the main window:

"You tried to change the QA Contact field from 6 to , but only the owner or
submitter of the bug, or a sufficiently empowered user, may change that field."

This is in regards to https://bugzilla.redhat.com/beta/show_bug.cgi?id=140167.

Not too sure how a QA contact field comes to be '6' when it looks pretty empty
to me.

To add myself to the CC list I just left the bug as is (entered no comment),
made sure that the "Add me to CC list" was ticked, and submitted.  (I was logged
in at the time).
Comment 1 David Lawrence 2004-11-22 11:17:40 EST
Changing to proper version.
Comment 2 Mike MacKenzie 2004-11-22 11:41:58 EST
   "Not too sure how a QA contact field comes to be '6' when it looks pretty empty
to me."  

That's the clue that helps me solve this one.  The QA contact when I look at
140167 is dkl@redhat.com, not blank.  It happens that dkl's userid in the
database is '6'.  So it looks like you accidenatlly blanked out the qa field
when you were working on the form.

Another possibility is that there is bug that is causing the qa field to be
blank when you (Reuben) look at it.  If you look at this and find this field is
blank by default for you, please reopen this bug.

I will a take a look at this error message text and see if it's possible to make
it a bit more helpful.  Especially getting it not to expose the internal user ids.
Comment 3 Reuben Farrelly 2004-11-22 16:31:08 EST
Reopened - the QA fields are always blank (in both IE and Firefox) with the beta
bugzilla http://bugzilla.redhat.com/beta/ , but not with the current (non beta)
version.  Even before entering anything the QA fields are blank immediately
after I log in.
This then causes bugzilla to complain when I submit any changes...
Comment 4 Bradley 2004-11-23 07:51:47 EST
I ran into this. It happens if you're not logged in. When submitting a
comment, after logging in, I got this. (For me it was the assignee,
not the qa)

You'll need an account without groups to repro this, I assume.
Comment 5 Bradley 2004-11-23 07:58:52 EST
The problem is that the new radio button fields for reassignment, which show up
if you're not logged in, aren't present on the login page as hidden fields. One
day I'll get rid of %::FORM....
Comment 6 Mike MacKenzie 2004-11-23 13:43:55 EST
I think the problem Bradley identified is different from the original bug.
I tracked Reuben's problem down to a bug in initializing the Bugzilla::Bug object.

It was removing the qa_contact when it should have been removing the
qa_whiteboard.  This is fixed in cvs, I'll have Dave push it out to the beta
when he is able (currently he's at the dentist...)

Note You need to log in before you can comment on or make changes to this bug.