Bug 1402306 - Can't find CMap Identity-UTF16-H
Summary: Can't find CMap Identity-UTF16-H
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler-data
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-07 08:44 UTC by Attila
Modified: 2016-12-11 21:54 UTC (History)
5 users (show)

Fixed In Version: poppler-data-0.4.7-6.fc25 poppler-data-0.4.7-6.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-11 19:27:29 UTC


Attachments (Terms of Use)

Description Attila 2016-12-07 08:44:36 UTC
Description of problem:
Running the command

gs -q -dNOPAUSE -dBATCH -dPDFSETTINGS=/prepress -sDEVICE=pdfwrite -sOutputFile=Output.pdf Input1.pdf Input2.pdf Input3.pdf

shows me an error as followed:

Can't find CMap Identity-UTF16-H building a CIDDecoding resource.
Warning: falling back to Identity ordering
Can't find CMap Identity-UTF16-H building a CIDDecoding resource. 
   **** Error: can't process embedded font stream,
        attempting to load the font using its name.
               Output may be incorrect.
Can't find CMap Identity-UTF16-H building a CIDDecoding resource. 
Warning: falling back to Identity ordering
Can't find CMap Identity-UTF16-H building a CIDDecoding resource. 
   **** Error reading a content stream. The page may be incomplete.
               Output may be incorrect.
   **** Error: File did not complete the page properly and may be damaged.
               Output may be incorrect.


Version-Release number of selected component (if applicable):
ghostscript-core-9.20-5.fc24.x86_64
ghostscript-9.20-5.fc24.x86_64
ghostscript-x11-9.20-5.fc24.x86_64
ghostscript-fonts-5.50-35.fc24.noarch


How reproducible:
Run the command (see above) with 3 PDF-Files. The Bug is always reproducible.


Steps to Reproduce:
1. Choose 3 PDF-Files of your choice. IMPORTANT! One of the PDF-Files must contain the font-type "CID TrueType". In my case "Arial CID TrueType".
2. Run the command (see above) in a terminal.


Actual results:
The output is incorrect and damaged.


Expected results:
The output should be correct.


Additional info:
One possible workaround is to link or copy the files from

/usr/share/ghostscript/9.16/Resource/CMap

to

/usr/share/ghostscript/9.20/Resource/CMap

Ghostscript is up to date (version 9.20-5) on my system.
However there are parts from version 9.16 where all the CMap files exist as a link to ../../../../poppler/cMap/. I think version 9.16 was not cleared completly.

The directory /usr/share/ghostscript/9.20/Resource/CMap is empty.

Comment 1 David Kaspar [Dee'Kej] 2016-12-08 16:53:18 UTC
Okay, so this is the problem of poppler-data:
http://pkgs.fedoraproject.org/cgit/rpms/poppler-data.git/tree/poppler-data.spec#n26

It is the package that provides the missing files, but this package has not been rebuilt since 9.16 was out.

I'm starting the rebuilt now, but this will have to be fixed somehow different in the future.

Thank you for pointing that out for us. :)

Best regards,

Dee'Kej

Comment 2 Rex Dieter 2016-12-08 17:04:34 UTC
Fwiw, if ghostscript could grow support for an unversioned data directory (in addition to standard versioned ones), then we could avoid rebuilding poppler-data for *every* ghostscript version bump.

Comment 3 Rex Dieter 2016-12-08 17:05:51 UTC
If ^^ is not feasible in the short-term, would you be ok with my filing a RFE tracking bug to add that feature to ghostscript packaging ?

Comment 4 David Kaspar [Dee'Kej] 2016-12-08 17:09:52 UTC
Rex, yes you're completely right. And it's actually on my todo-list right now. :)

The problem is a little bit more complex, because ghostscript consists of many parts that we actually package separately.

For me, first step is to deal with urw-fonts, which is the biggest pain in the a** right now, then to fix the ghostscript specfile (it's complete mess), and in that time fix poppler as well... :)

I hope this will be done by the time F26 will fork, but I don't plan to bring those changes back to F25 and older. IMHO, it could break something and I don't want to make Fedora unstable for our users.

Cheers,

Dee'Kej

Comment 5 Fedora Update System 2016-12-09 08:58:24 UTC
poppler-data-0.4.7-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d6a352eeca

Comment 6 Fedora Update System 2016-12-09 08:58:32 UTC
poppler-data-0.4.7-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6ecaf251f6

Comment 7 Fedora Update System 2016-12-09 08:58:39 UTC
poppler-data-0.4.7-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-975dfd5c27

Comment 8 Fedora Update System 2016-12-10 03:53:03 UTC
poppler-data-0.4.7-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6ecaf251f6

Comment 9 Fedora Update System 2016-12-10 03:57:18 UTC
poppler-data-0.4.7-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d6a352eeca

Comment 10 Fedora Update System 2016-12-10 04:28:53 UTC
poppler-data-0.4.7-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-975dfd5c27

Comment 11 Fedora Update System 2016-12-11 19:27:29 UTC
poppler-data-0.4.7-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-12-11 21:54:39 UTC
poppler-data-0.4.7-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.