Bug 1402406 - Client stale file handle error in dht-linkfile.c under SPEC SFS 2014 VDA workload
Summary: Client stale file handle error in dht-linkfile.c under SPEC SFS 2014 VDA work...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1388218
TreeView+ depends on / blocked
 
Reported: 2016-12-07 13:32 UTC by Dan Lambright
Modified: 2017-09-05 17:25 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1388218
Environment:
Last Closed: 2017-09-05 17:25:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-12-07 13:45:10 UTC
REVIEW: http://review.gluster.org/16055 (cluster/tier: Check for phase2 migration on EINVAL error) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 2 Worker Ant 2016-12-16 13:31:13 UTC
REVIEW: http://review.gluster.org/16163 (cluster/tier: Don't update cached subvol) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 3 Worker Ant 2017-05-12 12:04:18 UTC
COMMIT: https://review.gluster.org/16163 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 3fc67c062b379562b8b121d5eed042a58cbb0b26
Author: N Balachandran <nbalacha@redhat.com>
Date:   Fri Dec 16 18:55:28 2016 +0530

    cluster/tier: Don't update cached subvol
    
    tier_readdirp_cbk updates the cached subvol to
    the hot tier if it finds a linkto file.
    However, if no lookup has been sent to the hot tier,
    lower layers will not have updated the inode-ctx causing
    later fops to fail.
    
    Change-Id: Ib8a5e58a6e7fd7750cf6a0ea85da611aa24c7512
    BUG: 1402406
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: https://review.gluster.org/16163
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@gmail.com>
    Tested-by: Dan Lambright <dlambrig@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 4 Nithya Balachandran 2017-06-06 06:09:18 UTC
I'm reopening this as this will need another patch as well. That patch is still WIP.

Comment 5 Shyamsundar 2017-09-05 17:25:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.