Bug 140241 - alt-d doesn't delete ntp servers in firstboot (accelerator key collision)
alt-d doesn't delete ntp servers in firstboot (accelerator key collision)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 13:05 EST by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 10:15:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-11-21 13:05:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040804 Galeon/1.3.17

Description of problem:
Alt-d is listed as an accelertor for delete button the ntp setup part
of firstboot but alt-d has already been taken by the D of the Date and
time tab.

Version-Release number of selected component (if applicable):
firstboot-1.3.33-1

How reproducible:
Always

Steps to Reproduce:
(on an already initialised machine)
1. Log into X start a terminal and su your way to root. 
2. Delete /etc/sysconfig/firstboot and start /usr/sbin/firstboot .
3. Click Next.
4. Tick "Yes, I agree to License Agreement" and click Next.
5. Switch to the Network Time Protocol tab.
6. Tick Enable Network Time Protocol and click on a server in the
listbox so that it is highlighted.
7. Notice that the D of the Delete button is underlined. Press Alt-d
to delete the highlighted server.


Actual Results:
Switches to the Date & Time tab because the D of Date is underlined too.

Expected Results:
Highlighted server to be deleted.

Additional info:

The following was output on the console:
Traceback (most recent call last):
  File "/usr/share/system-config-date/date_gui.py", line 305, in
ntpSrvDelButtonClicked
    self.ntpServers.remove (host)

Related to bug 134172 which is almost the same thing but for the other
tab.
Comment 1 Nils Philippsen 2004-11-24 02:57:34 EST
Which version of system-config-date is installed ("rpm -q
system-config-date")?
Comment 2 Sitsofe Wheeler 2004-11-24 03:45:17 EST
system-config-date-1.7.11-1 (I think that's the only one that's been
released for FC3 outside of testing/rawhide).
Comment 3 Nils Philippsen 2004-11-26 11:33:40 EST
fixed in CVS
Comment 4 Nils Philippsen 2004-11-30 10:19:35 EST
fixed in system-config-date-1.7.14-0.RHEL4.1 (for en_* languages, other
languages might need their translations to be changed still).
Comment 5 Nils Philippsen 2004-11-30 10:21:40 EST
make that system-config-date-1.7.14-0.fc3.1 for Fedora Core 3 of course

Note You need to log in before you can comment on or make changes to this bug.