Bug 140250 - up2date translations and stings are outdated and can't be rebuild from source
up2date translations and stings are outdated and can't be rebuild from source
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 14:29 EST by Klaus Pedersen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.3.65
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 02:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date after the proposed patch (88.91 KB, image/png)
2004-11-21 14:31 EST, Klaus Pedersen
no flags Details
up2date before the proposed patch (116.63 KB, image/png)
2004-11-21 14:32 EST, Klaus Pedersen
no flags Details
The fix? (11.24 KB, patch)
2004-11-21 14:45 EST, Klaus Pedersen
no flags Details | Diff
New .po file for danish. (29.43 KB, text/plain)
2004-11-21 14:50 EST, Klaus Pedersen
no flags Details

  None (edit)
Description Klaus Pedersen 2004-11-21 14:29:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/0.9.3

Description of problem:
This bug report covers a few issues related to how l18n is handled.

For some time there have been an error in the danish translation,
that causes the up2date window to be larger than the screen. This
is caused by missing "\n" in some of the translated strings.

When FC3 came out, some of us expected that the already available
patch would be included, but that didn't happen. 
Instead many of the strings have now reverted to the original english
strings and even worse, it is no longer possible to build up2date 
from source.

There are 4 critical errors:

1) the Makefile points to python2.2, but FC3 ships with python2.3
2) firstboot.gladestrings is refrenced from po/Makefile, but it
   does not exist, which makes it impossible to run "make update-po"
3) the .gladestrings in po/ is out of date, which is the reason that
   many of the strings now appear un-translated.
4) As I see it there is no mechanism for the application in the sub-
   directory "firstboot", to get it's its translations.
   (It is setting gettext.textdomain ("firstboot"), but up2date 
    doesn't install anything there). 
   I guess that this instance of "firstboot" is obsolete.


A BUG WITH A FIX:

I have attached a patch that fixes the first 3 problems. 

Basically what the patch does is to take the strings directly from 
the .py and the .glade files, making the .gladestrings unnessary. 
This can be done directly with xgettext, which makes pygettext 
obsolete.






Version-Release number of selected component (if applicable):
up2date-4.3.47-5

How reproducible:
Always

Steps to Reproduce:
1.download up2date source rpm
2.cd into /usr/src/redhat/SOURCES/up2date-FC3-4.3.47/po
3.gmake update-po

or 

1.download up2date source rpm
2.cd into /usr/src/redhat/SOURCES/up2date-FC3-4.3.47/
3.gmake


Actual Results:  
ISSUE 1:
gmake: *** No rule to make target `firstboot.gladestrings', needed by
`up2date.pot'.  Stop.

ISSUE 2:
python -c "import py_compile; py_compile.compile('bootloadercfg.py')"
...
gcc -fPIC -Wall -O2 -fomit-frame-pointer -I/usr/include/python2.2 -c
-o dmimodule.o dmimodule.c
dmimodule.c:18:20: Python.h: No such file or directory
...


Expected Results:  I would expect make to finish without errors.

Additional info:

I have attached a screendumps of up2date before and after the patch. 
Please note how the splash screen before the patch is in english and 
*very* large.

up2date-FC3-4.3.47.patch.gz  
- The previously described patch, apply and run make update-po in 
  the po/ directory.

da.po.gz  
- compressed danish .po file which contains the strings actually used 
  by up2date.

up2date-before_patch.png

up2date-after_patch.png
Comment 1 Klaus Pedersen 2004-11-21 14:31:38 EST
Created attachment 107139 [details]
up2date after the proposed patch
Comment 2 Klaus Pedersen 2004-11-21 14:32:39 EST
Created attachment 107140 [details]
up2date before the proposed patch
Comment 3 Klaus Pedersen 2004-11-21 14:45:04 EST
Created attachment 107142 [details]
The fix?
Comment 4 Klaus Pedersen 2004-11-21 14:50:21 EST
Created attachment 107143 [details]
New .po file for danish. 

I guess that you will have to run "make update-po" before and after you
copy this file into the po/ directory.
Comment 5 Adrian Likins 2004-11-22 12:42:54 EST
issue #2 is python-devel not being installed.
Comment 6 Adrian Likins 2004-11-22 12:45:30 EST
issue #1 is a bit moot now, since the po/Makefile has
changed completely now (uses intl-tool, etc) in
latest builds. 

up2date-4.3.65 or newer should be landing in
rawhide soon, and should fix these issues. 

Note You need to log in before you can comment on or make changes to this bug.