Bug 140260 - FC3 alsa emu10k1 no spdif ac3 passthrough
FC3 alsa emu10k1 no spdif ac3 passthrough
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 15:54 EST by Zachary Whitley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 03:33:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zachary Whitley 2004-11-21 15:54:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
alsa-lib-1.0.6-3
alsa-utils-1.0.6-3

SBLive sound card.

I can enable digital output with alsamixer and pass PCM data to and
external reciever but using mplayer -ao alsa -ac hwac3 ... doesn't
pass ac3 to the receiver. The audio receiver detects a 5.1 stream but
goes in and out so I'm assuming the stream is corrupted somehow.

After reinstalling FC2 I can varify that spdif output works fine in
fc3. There are no errors in /var/log/messages I wish that I could post
some more diagnostic info but there are no errors to report other than
ac3 passthrough not working. /etc/modprobe is default from
system-config-soundcard and used alsamixer to unmute digital-out.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install fc3.
2. Enable digital-out with alsamixer
3. PCM fine. No ac3
    

Actual Results:  No ac3 output to external audio receiver.

Expected Results:  Receiver should have detected a 5.1 ditial signal

Additional info:

This works just fine in fc2.
Comment 1 Zachary Whitley 2004-11-22 11:42:54 EST
Someone else seems to be having the same problem with madrake on a 2.6
kernel...not much info.

http://www.linuxquestions.org/questions/history/252317
Comment 2 Lee Lassen 2005-01-12 04:42:22 EST
This seems to be a problem with the stock kernels for fedora core 3. I
tried downloading and compiling kernel 2.6.7 and 2.6.10 from
kernel.org. Running with these kernels the spdif works perfectly.
Also while running core 2 i experienced this problem when upgrading to
a new kernel (sorry can't remember which one, think it was
2.6.8-something).
Comment 3 Martin Stransky 2005-01-28 05:49:34 EST
And what about kernel in devel branch? Does it work too?
Comment 4 Zachary Whitley 2005-03-14 22:14:43 EST
Seems to be fine now with 2.6.10-1.741smp. You can probably close this.

Note You need to log in before you can comment on or make changes to this bug.