Bug 140261 - Early in the install the installer has a parted exception and exits
Early in the install the installer has a parted exception and exits
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 15:55 EST by Arian Prins
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arian Prins 2004-11-21 15:55:54 EST
When starting to install FC3 on a system (that has two harddisks, 
that are loaded with an old redhat-linux, winxp and win98) the 
installer has a parted exception and stops. 

It happens just a few steps after the graphical installsystem starts 
(after the questions about language and keyboard).

Version-Release number of selected component (if applicable):


How reproducible: Every Time


Steps to Reproduce:
1. Reboot with FC3 DVD in drive
2. Start installing with graphicall installer
3. After country/keyboard questions a popup named "bug" warns 
thatthere has been a parted exception and offers the choice to ignore 
or cancel. I choose ignore.
4. Another popup shows, also named "bug" also with a warning 
concerning a parted exception with also the choice ignore and cancel. 
I choose ignore.
5. Installer shuts down (shows the system shutdown, and the 
message "it is now safe to reboot").
    
  
Actual results:


Expected results:
Probably the partition-editor should have started at this point.

Additional info:
The ALT-F1 screen has this info (I had to write it down and now type 
it out since copy and paste were of no use, so pardon the 
spelling/other small mistakes there might be):
.....
Starting Graphical Installation......
Bug
Assertion (heads > 0) at disk_dos.c: 485 in function 
probe_partition_for_geom() failed.
96
Bug
Assertion (sectors <= 63) at disk_dos.c: 485 in function 
probe_partition_for_geom() failed.
96
Installer exited abnormally
....
ALT-F3 screen:
....
* moving (1) to step keyboard
* running ['/usr/X11R86/bin/setxkbmap','-layout','us','-
model','pc105','-option','']
* moving(1) to step findrootparts
* parted exception: Bug: Assertion (heads > 0) at disk_dos.c: 485 in 
function probe_partition_for_geom() failed.
* parted exception: Bug: Assertion (sectors <= 63) at disk_dos.c: 485 
in function probe_partition_for_geom() failed.
......
Comment 1 Jeremy Katz 2004-11-22 11:14:26 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.