Bug 1402670 - Cannot subscribe to any of Pocket, Google, ownCloud accounts
Summary: Cannot subscribe to any of Pocket, Google, ownCloud accounts
Keywords:
Status: CLOSED DUPLICATE of bug 1340203
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-08 06:12 UTC by Matěj Cepl
Modified: 2018-04-11 19:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-08 15:32:04 UTC


Attachments (Terms of Use)
output of journalctl -xb (5.26 MB, text/plain)
2016-12-08 06:12 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2016-12-08 06:12:18 UTC
Created attachment 1229353 [details]
output of journalctl -xb

Description of problem:
After the reboot, all my GOA accounts are shown as having expired signins. When signing in to each individual account from the above mentioned everything seems to go smoothly, but the exclamation mark for the account doesn’t go away and truly Evolution cannot access resources in the account in question.

The only exception is the Kerberos account, which get signed in correctly.

$HOME is originally from RHEL-7 upgraded to F25

Version-Release number of selected component (if applicable):
libsecret-0.18.5-2.fc25.x86_64
gnome-online-accounts-3.22.2-1.fc25.x86_64

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.

Actual results:
cannot sign in to my non-Kerberos accounts

Expected results:
everything should work smoothly or at least reasonable error message should br provided

Additional info:
Perhaps duplicate of bug 1350678 or bug 1378370 ?

Comment 1 Debarshi Ray 2016-12-08 10:16:06 UTC
(In reply to Matěj Cepl from comment #0)
> Created attachment 1229353 [details]
> output of journalctl -xb
> 
> Description of problem:
> After the reboot, all my GOA accounts are shown as having expired signins.
> When signing in to each individual account from the above mentioned
> everything seems to go smoothly, but the exclamation mark for the account
> doesn’t go away and truly Evolution cannot access resources in the account
> in question.

Are you sure you rebooted? Or did you log out/in?

The following makes me think that it is a duplicate of bug 1340203:

 goa-daemon[2436]: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.12 was not provided by any .service files
 goa-daemon[2436]: secret_password_lookup_sync() failed: The name :1.12 was not provided by any .service files
 goa-daemon[2436]: /org/gnome/OnlineAccounts/Accounts/account_1460036629_1: Setting AttentionNeeded to FALSE because EnsureCredentials() succeded
 gnome-keyring-daemon[2529]: asked to register item /org/freedesktop/secrets/collection/Default/214, but it's already registered
 goa-daemon[2436]: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.12 was not provided by any .service files
 goa-daemon[2436]: secret_password_lookup_sync() failed: The name :1.12 was not provided by any .service files

Long story short, since the change to D-Bus user buses set up by systemd --user in Fedora 24, session daemons are no longer terminated on log out. So, even when you log out, your goa-daemon process keeps running. gnome-keyring, on the other hand, is an exception because it is tied to PAM and terminates. When you log back in, the old goa-daemon cannot talk to the new gnome-keyring and things fall apart.

There is nothing we can do about this in gnome-online-accounts. We need to fix the way D-Bus is getting set up.

Comment 2 Matěj Cepl 2016-12-08 15:32:04 UTC
(In reply to Debarshi Ray from comment #1)
> Are you sure you rebooted? Or did you log out/in?

Yes, that's probably it. Thank you pointing me in the right direction.

*** This bug has been marked as a duplicate of bug 1340203 ***


Note You need to log in before you can comment on or make changes to this bug.