Bug 140270 - kernel-2.6.9-1.3 doesn't see sata drive
kernel-2.6.9-1.3 doesn't see sata drive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 17:49 EST by PPi
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-21 23:08:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description PPi 2004-11-21 17:49:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Running kernel-2.6.5-1.358 or kernel-2.6.5-1.358smp, fdisk -l
correctly shows my two harddrives:

Disk /dev/hda: 100.0 GB, 100030242816 bytes
16 heads, 63 sectors/track, 193821 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
 
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1       31208    15728800+  83  Linux
/dev/hda2   *       31209      193821    81956952    7  HPFS/NTFS
 
Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         653     5245191    7  HPFS/NTFS
/dev/sda2             654        1958    10482412+   7  HPFS/NTFS
/dev/sda3            1959       30401   228468397+   f  W95 Ext'd (LBA)
/dev/sda5            1959        2219     2096451   82  Linux swap
/dev/sda6            2220        3524    10482381    7  HPFS/NTFS
/dev/sda7            3525        5957    19543041    b  W95 FAT32

When running kernel-2.6.9-1.3 or kernel-2.6.9-1.3smp, /dev/sda is no
longer there.

/dev/hda is a 100 GB WD drive
/dev/sda ia a 250 GB Hitachi (SATA) drive

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.3

How reproducible:
Always

Steps to Reproduce:
1. Boot w/ kernel-2.6.5-1.358(smp)
2. fdisk -l
3. Boot w/ kernel-2.6.9-1.3(smp)
4, fdisk -l
    

Additional info:
Comment 1 Dave Jones 2004-11-21 23:08:47 EST
fixed in -1.6 (in testing, due to move to final updates).

Note You need to log in before you can comment on or make changes to this bug.