Bug 1402772 - Endpoint type is ignored for network commands
Summary: Endpoint type is ignored for network commands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 9.0 (Mitaka)
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Julie Pichon
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-08 10:17 UTC by Simon Reber
Modified: 2017-05-17 19:50 UTC (History)
11 users (show)

Fixed In Version: python-openstackclient-3.8.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
The '--os-interface' switch was ignored by 'openstack network' commands. Consequently, all such commands used the 'public' endpoint, although other interfaces were specified. The support for the switch has been added. Now the 'openstack network' commands correctly use the endpoint specified in '--os-interface' switch.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:50:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 329382 None None None 2016-12-08 10:18:55 UTC
OpenStack gerrit 329420 None None None 2017-01-26 10:16:33 UTC
Launchpad 1592368 None None None 2016-12-08 10:17:55 UTC

Description Simon Reber 2016-12-08 10:17:13 UTC
Description of problem:

If there are several network endpoint types defined:

$ openstack endpoint list |grep neutron
| 097fb40857b64fdcaf609dbc8c85663b | region1 | neutron | network | True | admin | https://192.168.245.5:9696/ |
| 25ed4d64a9d44cb59f2f280038b722d9 | region1 | neutron | network | True | internal | https://192.168.245.5:9696/ |
| 42142cf6067248ab90c4771cb8a39bb0 | region1 | neutron | network | True | public | https://foobar.test:9696/ |

All "openstack network xxx" commands hit the public endpoint, even if OS_ENDPOINT_TYPE or --os-interface are specified.

Version-Release number of selected component (if applicable):

Red Hat OpenStack Platform 9

How reproducible:

always

Steps to Reproduce:
1. See https://bugs.launchpad.net/python-openstackclient/+bug/1592368

Actual results:

Public endpoint is always hit

Expected results:

Specified endpoint should be hit (if defined)

Additional info:

https://bugs.launchpad.net/python-openstackclient/+bug/1592368
https://git.openstack.org/cgit/openstack/python-openstackclient/commit/?id=7c603e4a67c3d44367afbf2f2f6811d2436295e0

Comment 1 Ola Pavlenko 2017-01-11 15:52:27 UTC
The upstream fix was merged
Moving to post

Comment 5 Julie Pichon 2017-01-26 10:16:33 UTC
There is a Mitaka (9.0) backport slowly making its way upstream.

Comment 8 Julie Pichon 2017-04-10 12:32:44 UTC
The Mitaka patch merged upstream. Once upstream tags a new release we can rebase the new version into OSP9. I'll add a link to the rebase bug once it is open.

Comment 11 errata-xmlrpc 2017-05-17 19:50:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.