Bug 140290 - Support for power management on Apple laptops
Summary: Support for power management on Apple laptops
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-22 03:19 UTC by W. Michael Petullo
Modified: 2014-03-17 02:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 18:45:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2004-11-22 03:19:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.3)
Gecko/20041027 Epiphany/1.4.4

Description of problem:
Benjamin Herrenschmidt has brought sleeping back to Apple's current
line of PowerBooks and iBooks.  In anticipation of this getting into
the mainstream kernel, it would be nice if the Fedora Project provided
a pmud package.  Pmud, a daemon that performs power-related functions
on Apple computers, is provided as an RPM package by Yellow Dog Linux 4.0.

Version-Release number of selected component (if applicable):
kernel-2.6.9

How reproducible:
Always

Steps to Reproduce:
Notice that closing the lid on a G4 iBook does not put the computer to
sleep.
    

Additional info:

Comment 1 Dave Jones 2004-11-27 20:46:47 UTC
new package request -- reassigning to distribution.

Comment 2 W. Michael Petullo 2004-12-01 16:03:40 UTC
For the record, Ben's kernel patch is available at
http://gate.crashing.org/~benh/albook-ibookg4-sleep-6.diff.  This
patch adds support to the kernel for the power management unit in G4
iBooks.

Comment 3 W. Michael Petullo 2004-12-29 19:37:15 UTC
There is a newer patch vs. 2.6.9 available at
http://gate.crashing.org/~benh/albook-ibookg4-sleep-7.diff.  When he
released this patch, Ben said:

> So here's the new patch, it replaces the previous one for Aluminium
> PowerBooks, and is still against 2.6.9. I'll do something against 
> 2.6.10 when that one is out (it's a bit late to get that merged with 
> Linus, 2.6.10 is in freeze mode now) and I hope to get all of that 
> in 2.6.11.

So perhaps we will see this stuff in the Fedora kernel once 2.6.11 is
released.

Comment 4 W. Michael Petullo 2005-02-03 16:29:09 UTC
It looks like Ben's patch is in 2.6.11-rc3.  The ChangeLog says:

> <benh@kernel.crashing.org>
>       [PATCH] ppc32: pmac sleep support update
>
>       This patch updates the PowerMac sleep support. [...]

Comment 5 Bill Nottingham 2005-03-02 22:11:35 UTC
I'm not averse to pmud if we're shipping PPC for FC4.

Comment 6 W. Michael Petullo 2005-04-20 18:45:43 UTC
Apmud is now in Fedora Extras and the Fedora kernel supports power managment on
new Apple computers.


Note You need to log in before you can comment on or make changes to this bug.