Bug 140294 - Installer fails on disks with out-of-disk-order partitions
Installer fails on disks with out-of-disk-order partitions
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 23:07 EST by Darryl Dixon
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl Dixon 2004-11-21 23:07:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
A bug has been detected in GNU parted.  Please email a bug report to
bug-parted@gnu.org containing the version (1.6.15) and the following
message:Assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed.
Error: Unable to satisfy all constraints on the partition.

Version-Release number of selected component (if applicable):
parted-1.6.15

How reproducible:
Always

Steps to Reproduce:
1.Partition disk so that partitions are numbered out-of-disk-order
2.Run installer to attempt to upgrade an old FC install
3.Installer fails when attempting to detect old installs to upgrade
    

Actual Results:  Installer fails with a popup window labelled 'BUG'
with the following contents:
Assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed.

Expected Results:  Installer should detect previous FC install and
upgrade correctly.

Additional info:

This is a bug in version 1.6.15 of parted.  The full error output
(from external testing) is:

A bug has been detected in GNU parted.  Please email a bug report to
bug-parted@gnu.org containing the version (1.6.15) and the following
message:Assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed.
Error: Unable to satisfy all constraints on the partition.
Error: Can't have the end before the start!

After discussions with the parted development team, they advised to
test version 1.6.18; I did so and this version does indeed function
correctly.

An example partiton layout that triggers this bug is:

Disk /dev/hda: 36.8 GB, 36848527872 bytes
240 heads, 63 sectors/track, 4759 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          16      120928+  83  Linux
/dev/hda2              17          51      264600   82  Linux swap
/dev/hda3              52         745     5246640   8e  Linux LVM
/dev/hda4             746        4759    30345840    5  Extended
/dev/hda5            1301        1335      264568+  83  Linux
/dev/hda6            1336        2924    12012808+  8e  Linux LVM
/dev/hda7            2925        4110     8966128+  8e  Linux LVM
/dev/hda8            4111        4759     4906439+  8e  Linux LVM
/dev/hda9             746        1300     4195768+  8e  Linux LVM

Note that hda9 is actually at the start of the extended partition,
even though it is labelled as the last.
Comment 1 Jeremy Katz 2004-11-22 11:16:29 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.