Bug 140301 - sdl-config --libs outputs insufficient parameters
Summary: sdl-config --libs outputs insufficient parameters
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-22 06:54 UTC by Alexandr Kara
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 13:54:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandr Kara 2004-11-22 06:54:52 UTC
Description of problem:

I am using SDL 1.2.0 on FedoraCore 2 and had problems compiling QEMU
emulator with SDL. It didn't recognize that SDL was installed.
I tracked the problem down to a test where it tried to compile a test
program with SDL using output from 'sdl-config --libs'.
The program didn't compile because it didn't link with X11 and Xext
libs (and libSDL-1.2.so.0 requires them).

When I changed
    --libs)
      libdirs="-L/usr/lib "
      echo $libdirs -lSDL -lpthread
      ;;
to
    --libs)
      libdirs="-L/usr/lib "
      echo $libdirs -lSDL -lpthread  -L/usr/X11R6/lib -lX11 -lXext
      ;;
it worked.

Version-Release number of selected component (if applicable):
1.2.0

How reproducible:
Always

Steps to Reproduce:
1. Get qemu-0.6.1 from
http://fabrice.bellard.free.fr/qemu/qemu-0.6.1.tar.gz
2. Run ./configure
  
Actual results:
SDL support: no
WARNING: cannot compile statically with SDL - qemu-fast won't have a
graphical output

Expected results:
SDL support: yes


Additional info:

Comment 1 Matthew Miller 2005-04-26 15:22:18 UTC
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Comment 2 Thomas Woerner 2006-01-27 13:54:45 UTC
Closing as WONTFIX, because FC-2 is maintained by the Fedora Legacy project.



Note You need to log in before you can comment on or make changes to this bug.