Bug 1403195 - snapshot creation will fail if the create is executed while brick is coming up
Summary: snapshot creation will fail if the create is executed while brick is coming up
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: Vinayak Papnoi
URL:
Whiteboard:
Depends On:
Blocks: 1351530
TreeView+ depends on / blocked
 
Reported: 2016-12-09 12:01 UTC by Rahul Hinduja
Modified: 2019-06-03 06:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Snapshot create might fail, if a brick has started but not all translators have initialized.
Clone Of:
Environment:
Last Closed: 2018-10-16 06:28:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rahul Hinduja 2016-12-09 12:01:24 UTC
Description of problem:
=======================

As part of the fix for bz: 1401817, snapshot creation will fail in a racy scenario where barrier brick op will fail while bricks are coming up, due to this snapshot creation will fail too. 

Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.8.4-6.el7rhgs.x86_64

How reproducible:
=================

Its a race

Steps to Reproduce:
===================
1. Create 2*2 distributed replicate volume
2. enabled scheduler,
3. scheduled snapshot every one minute, while snapshot are getting created bring bricks offline/online.

Comment 4 Bhavana 2017-03-13 15:39:46 UTC
Hi Avra,

I wanted to check if there is any workaround for this issue.

Comment 5 Avra Sengupta 2017-03-14 05:29:04 UTC
Hi Bhavana,

The doc text looks good. But there is no workaround to this problem. The snapshot create will fail and needs to be retried.

Comment 7 Mohammed Rafi KC 2017-08-17 07:20:09 UTC
Since barrier xlator enable or disable was failed because of the graph initialization , then I think it is an expected failure. As long as it fail properly then it won't create any problem. Unless there is any un-recoverable problem with the failure, we don't need to keep this bug open.


Note You need to log in before you can comment on or make changes to this bug.