Bug 14032 - Add shared version of libpcap library
Add shared version of libpcap library
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-15 09:45 EDT by borgia
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 05:58:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description borgia 2000-07-15 09:45:28 EDT
libpcap is not listed, at least not in the beta page or in ptools beta one. 

I wanted to ask that a devel subpackage be created to house a static version and 
headers, leaving the main pkg with a shared version (that now it is not available). 
I volounteer to do it.
Comment 1 Pekka Savola 2000-08-03 08:21:43 EDT
The package used is (currently) specified by source package (which in turn can
be seen with e.g. 'rpm -qi libpcap').

Here, it's tcpdump.
Comment 2 David Lawrence 2000-08-03 10:34:48 EDT
Bugzilla currently separates the components by source rpm. There has been talk
of changing over to using binary rpms which is less confusing but would also
substantially increase the amount of components to choose from which would slow
Bugzilla down in certain areas. So a re-design will be needed before this can be
switched over.
Comment 3 Andrea Borgia 2000-08-03 15:27:02 EDT
Yes, but getting back to my original question: how about making a shared version of libpcap?
Comment 4 David Lawrence 2000-08-04 15:01:31 EDT
Changing to Red Hat Linux Beta with component of tcpdump.
Comment 5 Jeff Johnson 2000-08-04 16:36:24 EDT
Making libpcap shared is risky because of ANK's modifications, the API is
different than
the older libpcap API. Deferred until tcpdump-3.5 is considered for inclusion.
Comment 6 Jeff Johnson 2001-01-08 12:30:55 EST
Deferred until tcpdump-3.6 is out, probably in a couple of months.

Note You need to log in before you can comment on or make changes to this bug.