Bug 1403216 - fc25 ppc64 iso kickstart firewall test reports missing libcript.so
Summary: fc25 ppc64 iso kickstart firewall test reports missing libcript.so
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-repos
Version: 25
Hardware: ppc64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-12-09 12:53 UTC by Michel Normand
Modified: 2017-04-23 14:32 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-04-23 14:32:36 UTC


Attachments (Terms of Use)
fc25_ppc64_ks_firewall_failure.png (249.86 KB, image/png)
2016-12-09 12:53 UTC, Michel Normand
no flags Details
_boot_to_anaconda_logs.tgz (82.15 KB, application/x-gzip)
2016-12-09 13:13 UTC, Michel Normand
no flags Details

Description Michel Normand 2016-12-09 12:53:43 UTC
Created attachment 1229956 [details]
fc25_ppc64_ks_firewall_failure.png

Description of problem:
fc25 ppc64 iso kickstart firewall test reports missing libcript.so

Version-Release number of selected component (if applicable):
fc25 ppc64 iso from 
https://download.fedoraproject.org/pub/fedora-secondary/releases/25/Server/ppc64/iso/Fedora-Server-dvd-ppc64-25-1.2.iso

How reproducible:
https://fedoraproject.org/wiki/QA:Testcase_kickstart_firewall

Steps to Reproduce:
if you have an openQA instance for fedora PowerPC then simply execute command:
===
/var/lib/openqa/script/client jobs post ISO=Fedora-Server-dvd-ppc64-25.iso DISTRI=fedora VERSION=25 FLAVOR=Server-dvd-iso ARCH=ppc64 BACKEND=qemu BUILD=Server-25-GA GRUB="inst.ks=http://fedorapeople.org/groups/qa/kickstarts/firewall-configured-net.ks" KICKSTART=1 MACHINE=ppc64 OFW=1 POSTINSTALL=firewall_configured QEMU=ppc64 QEMUCPU=host QEMURAM=4096 ROOT_PASSWORD=anaconda TEST=install_kickstart_firewall_configured USER_LOGIN=false VGA=std WORKER_CLASS=qemu_ppc64
===

Actual results: popup error message about missing packages as per
attached fc25_ppc64_ks_firewall_failure.png
like:
===
nothing provides libcrypt.so.1()(64bit)
nothing provides glibc-common = 2.24-3.fc25
...
===


Expected results:


Additional info:
* There is no such problem for same test executed for ppc64le.

Comment 1 Michel Normand 2016-12-09 13:13 UTC
Created attachment 1229960 [details]
_boot_to_anaconda_logs.tgz

related logs

Comment 2 Éric Fintzel 2016-12-09 14:19:44 UTC
On the http://dl.fedoraproject.org/pub/fedora-secondary/releases/25/Everything/ppc64/os/Packages/l/ page (and associated mirrors), libcrypt is only provided for ppc64p7:

libcrypt-2.24-3.fc25.ppc64p7.rpm


For Server packages (i.e http://dl.fedoraproject.org/pub/fedora-secondary/releases/25/Server/ppc64/os/Packages/l/ and mirrors) both versions are provided (ppc64 and ppc64p7):

glibc-2.24-3.fc25.ppc64.rpm
glibc-2.24-3.fc25.ppc64p7.rpm


The error is probably due to the missing libcrypt-2.24-3.fc25.ppc64.rpm package in case of the "Everything" flavour.

Comment 3 Dan Horák 2016-12-12 17:31:08 UTC
oh my, the subarch issue with the compose tools again :-(

Comment 4 Peter Robinson 2016-12-13 02:33:15 UTC
(In reply to Dan Horák from comment #3)
> oh my, the subarch issue with the compose tools again :-(

So it's too late to fix this for F-25 now, should have tested it properly, and we've killed ppc64p7 in F-26 due to these issues, so I'm not sure how best to deal with it. Updated glibc into updates will fix the issue for F-25 but not for install media. F-26 there won't be a problem. That's likely about the best we can fix it.

Comment 5 Michel Normand 2017-03-06 16:17:00 UTC
Assuming this bug is limited to ppc64 f25 install media that will not be fixed as per above comment #4
I have created a new bug https://bugzilla.redhat.com/show_bug.cgi?id=1429575
to track the upgrade that is failing now with last  f25 updates.

Comment 6 Peter Robinson 2017-04-23 14:32:36 UTC
Closing this can't fix, F-25 is long out, won't be an issue with F-26


Note You need to log in before you can comment on or make changes to this bug.