Bug 140376 - make rpm error
make rpm error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 12:41 EST by David Hart
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 03:12:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hart 2004-11-22 12:41:09 EST
Description of problem:

Installation of rpm created by "make rpm" does not create
initrd-2.6.9-1.681_FC3.img nor does it update grub.conf.

Version-Release number of selected component (if applicable):

Kernel 2.6.9-1.681_FC3

Steps to Reproduce:
1. Build source rpm from src.rpm
2. Install src.rpm
3. make mrproper
4. make menuconfig  
5. make rpm
6. rpm -ivh kernel-2.6.9-1.681_FC3.i386.rpm

Actual results:

Creates system.map and vmlinuz files

Expected results:

Create system.map, vmlinuz and initrd-xxx.img. Udate grub.conf

Additional info:
Comment 1 Keoni Morrell 2005-07-11 07:01:51 EDT
Also, the "make rpm" command exits with an error if you are appending a custom
string to your kernel:

Version-Release number of selected component:

kernel-source 2.6.10-1.771_FC2

Steps to Reproduce:
1. make menuconfig
2. type in a string under General Setup -> Local version - append to kernel release
3. exit saving changes
4. make rpm

Actual results:
error: File /usr/src/kernel-2.6.101.771_FC2custom.tar.gz: No such file or directory

Expected results:

Create an rpm

Additional info: 

I would gladly fix this problem if I could figure out how to download the latest
and greatest kernel and submit the patch.  :)
Comment 2 Dave Jones 2005-07-15 16:23:23 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Dave Jones 2005-07-28 03:12:48 EDT
I'd suggest fixing this upstream. make rpm isn't something that gets any
attention in Fedora. 

Note You need to log in before you can comment on or make changes to this bug.