Bug 1403951 - virt-manager should support and default to external snapshots
Summary: virt-manager should support and default to external snapshots
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: FutureFeature
: 1342543 1686842 (view as bug list)
Depends On: 1519002 1402581
Blocks: 1519003 1214187 1431852
TreeView+ depends on / blocked
 
Reported: 2016-12-12 17:09 UTC by Ademar Reis
Modified: 2019-03-08 13:40 UTC (History)
14 users (show)

(edit)
Clone Of: 1402581
: 1519003 (view as bug list)
(edit)
Last Closed: 2018-10-22 12:46:26 UTC


Attachments (Terms of Use)

Description Ademar Reis 2016-12-12 17:09:27 UTC
We don't encourage the usage of qcow2 internal snaphots but virsh and virt-manager both default to them when creating snapshots.

BZ 1402581, reproduced below, is the virsh version of this issue.

+++ This bug was initially created as a clone of Bug #1402581 +++

Description of problem:
For historical reasons, 'virsh snapshot-create' defaults to internal snapshots, because external snapshots were not implemented for several years.  However, these days the qemu team recommends the use of external snapshots, and upper levels like RHEV prefer external snapshots.  It would be nice if there were a way to set up configuration defaults for virsh, so that typing 'virsh snapshot-create' could consult the configuration file on whether to default to internal or external, instead of forcing the user to remember to pass extra flags to get an external snapshot.

Version-Release number of selected component (if applicable):
libvirt-2.5.0-1.el7

Comment 4 Cole Robinson 2017-03-02 20:11:22 UTC
*** Bug 1342543 has been marked as a duplicate of this bug. ***

Comment 6 Cole Robinson 2018-10-22 12:46:26 UTC
Closing this as CANTFIX for rhel7. Besides not being implemented at the lower levels yet, even if virt-manager.git got support tomorrow it would very likely require a rebase for RHEL7, which is impossible as upstream virt-manager has moved to python3. Please reopen if I've missed something

Comment 7 Pavel Hrdina 2019-03-08 13:40:33 UTC
*** Bug 1686842 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.