Bug 1404028 - Folder relationship change causing a re-classify of all children VMs
Summary: Folder relationship change causing a re-classify of all children VMs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: GA
: 5.8.0
Assignee: Adam Grare
QA Contact: Alex Newman
URL:
Whiteboard:
: 1403394 (view as bug list)
Depends On:
Blocks: 1404526 1404527 1412279
TreeView+ depends on / blocked
 
Reported: 2016-12-12 21:46 UTC by Jared Deubel
Modified: 2020-02-14 18:18 UTC (History)
8 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1404526 1404527 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:40:32 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Jared Deubel 2016-12-12 21:46:22 UTC
Description of problem:
Folder relationship change causing a re-classify of all children VMs. It seems that it should only re-classify VMs if the folder changed, not if a vm was added to a folder. When we provision a VM it changes the taggings for every VM which takes a long time to replicate


Version-Release number of selected component (if applicable):
5.6.3

Comment 3 CFME Bot 2016-12-13 15:55:58 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/aeb4f6acf3174a990864802b6b49ea4e93d71571

commit aeb4f6acf3174a990864802b6b49ea4e93d71571
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Mon Dec 12 18:54:10 2016 -0500
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Tue Dec 13 01:13:20 2016 -0500

    Only reclassify VMs if they were changed directly
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1404028

 app/models/vm_or_template.rb | 34 ++++++++++++++++++++++++----------
 1 file changed, 24 insertions(+), 10 deletions(-)

Comment 4 CFME Bot 2016-12-13 15:56:03 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c39789d11f7c47b45cd2cf00c0789fbcdc2705ae

commit c39789d11f7c47b45cd2cf00c0789fbcdc2705ae
Author:     Jason Frey <jfrey@redhat.com>
AuthorDate: Tue Dec 13 01:05:45 2016 -0500
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Tue Dec 13 01:13:32 2016 -0500

    Add specs for VmOrTemplate.post_refresh_ems
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1404028

 spec/factories/ems_folder.rb       |  79 +++++++++++++++++++
 spec/models/vm_or_template_spec.rb | 151 +++++++++++++++++++++++++++++++++++++
 2 files changed, 230 insertions(+)

Comment 7 Josh Carter 2017-01-11 22:16:04 UTC
*** Bug 1403394 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.