Bug 1404158 - Need to double click to uncheck already exist checkbox
Summary: Need to double click to uncheck already exist checkbox
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Konecny
QA Contact: Release Test Team
Filip Hanzelka
URL:
Whiteboard:
Keywords:
Depends On: 1448187
Blocks: 1395321
TreeView+ depends on / blocked
 
Reported: 2016-12-13 08:53 UTC by Vit Ry
Modified: 2017-08-01 08:53 UTC (History)
8 users (show)

(edit)
Deselecting an "add-on" option in "Software Selection" no longer requires a double-click

When installing Red Hat Enterprise Linux 7.3, the user had to double-click in order to deselect an "add-on" checkbox after a "Base environment" change. The bug occurred in the "Software Selection" dialogue of the graphical installation. 
With this update, the system no longer requires double-clicking when deselecting an option after a "Base environment" change. A single click is sufficient.
Clone Of:
(edit)
Last Closed: 2017-08-01 08:53:21 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2293 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Description Vit Ry 2016-12-13 08:53:28 UTC
Description of problem:

In software selection dialog you need to double-click to uncheck already exist check box (checked by comps) or after Environment change


Version-Release number of selected component (if applicable):

RHEL7.3 / Fedora-rawhide
anaconda-21.48.22.93-1


How reproducible:

Always


Steps to Reproduce:
1. Start installer, go to Software selection
2. Check 'Debugging Tools' on the right
3. Click 'Infrastructure Server' on the left
4. As you see, 'Debugging Tools' already checked. Click 1 time to uncheck it


Actual results:

Nothing happens (line just selected). You need to press twice to uncheck add-on


Expected results:

'Debugging Tools's box become unchecked after first click on check box.


Additional info:
* RHEL7.2 - affected
* Fedora-rawhide - affected

Looks like regression, since it works fine in RHEL-7.0 (7.1 maybe too)

Comment 1 Vit Ry 2016-12-13 11:27:48 UTC
UPDATE: 

Steps to reproduce on Fedora-Everything-netinst-x86_64-Rawhide-20161211.n.0.iso

(1) Go to XFCE desktop environment and try to uncheck 'Application for the Xfce Desktop'

(2) Go to 'Minimal install', check 'Standard', go to 'Fedora server edition' env, go back to 'Minimal install', try to uncheck 'Standard' check box.
this case only for 'common' groups (shared between envs)


P.s. Also, as proposal, how about scrolling right-pane (add-Ons) to the top, when user switches 'environment' on the right. 
Try to scroll to middle of add-ons pane and switch envs. A bit weird  that you find yourself in the middle/in the end of list

Comment 3 Jiri Konecny 2017-03-08 14:19:03 UTC
PR: https://github.com/rhinstaller/anaconda/pull/987

Comment 5 Fedora Update System 2017-04-28 13:28:53 UTC
anaconda-26.21.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f620d8c7c2

Comment 6 Fedora Update System 2017-04-30 03:52:20 UTC
anaconda-26.21.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f620d8c7c2

Comment 7 Jiri Konecny 2017-05-11 09:23:52 UTC
I'm sorry for that but this bug caused regression which is already reported bug 1448187 . Fix for this is on its way.

Comment 13 errata-xmlrpc 2017-08-01 08:53:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.