Bug 1404214 - tuned post script error message
tuned post script error message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-13 06:33 EST by Marko Myllynen
Modified: 2017-08-01 08:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: tuned-2.8.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 08:32:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2016-12-13 06:33:35 EST
Description of problem:
tuned.rpm has this in its posttrans scriptlet:

  selinuxenabled && restorecon /etc/grub.d/00_tuned || :

If selinuxenabled is not present an error message in printed during RPM transaction.
Comment 2 Jaroslav Škarvada 2017-01-25 04:01:18 EST
Fixed by following upstream commit:
https://github.com/redhat-performance/tuned/commit/b088337d3d9db17c8e7f90656a56fa503567e752
Comment 4 Tereza Cerna 2017-04-26 07:59:29 EDT
================================
Verified in:
    tuned-2.8.0-2.el7.noarch
PASS
================================

# rpm -q tuned libselinux-utils
package tuned is not installed
package libselinux-utils is not installed

# yum install tuned-2.8.0-2.el7.noarch.rpm 
...
Running transaction
  Installing : tuned-2.8.0-2.el7.noarch                                                           1/1 
  Verifying  : tuned-2.8.0-2.el7.noarch                                                           1/1 

Installed:
  tuned.noarch 0:2.8.0-2.el7                                                                          

Complete!



================================
Reproduced in:
    tuned-2.7.1-3.el7_3.1.noarch
FAIL
================================

# rpm -q tuned libselinux-utils
package tuned is not installed
package libselinux-utils is not installed

# yum install tuned-2.7.1-3.el7_3.1.noarch.rpm 
...
Running transaction
  Installing : tuned-2.7.1-3.el7_3.1.noarch                                                       1/1 
/var/tmp/rpm-tmp.DNGXFt: line 5: selinuxenabled: command not found
  Verifying  : tuned-2.7.1-3.el7_3.1.noarch                                                       1/1 

Installed:
  tuned.noarch 0:2.7.1-3.el7_3.1                                                                      

Complete!

>> There is error with uninstalled selinux.
Comment 5 errata-xmlrpc 2017-08-01 08:32:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2102

Note You need to log in before you can comment on or make changes to this bug.