Bug 140423 - Kernel hand with __getblk_slow()
Kernel hand with __getblk_slow()
Status: CLOSED DUPLICATE of bug 140424
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-22 15:51 EST by sheryl sage
Modified: 2015-01-04 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-22 16:30:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description sheryl sage 2004-11-22 15:51:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
kernel hang that we think is a bug with __getblk_slow(). 
This bug is causing the TCs to hang immediately, while /sbin/sfdisk 
tries to read the geometry(trying to read block 0). "sfdisk" command 
is not always failing, but at the time of running test cases, it is 
causing the hang immediately. 

The implementation of "__getblk_slow()" seems to be causing this. 
This function has to return the "buffer_head" structure for the given 
block. For this it is trying to get buffer_head by 
calling "__find_get_block" and "grow_buffers()" 


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
will attach

Additional info:
Comment 1 Dave Jones 2004-11-22 16:30:00 EST

*** This bug has been marked as a duplicate of 140424 ***

Note You need to log in before you can comment on or make changes to this bug.