Bug 1404255 - awscli requires python3-PyYAML
Summary: awscli requires python3-PyYAML
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: awscli
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabio Alessandro Locati
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-13 13:35 UTC by Diego
Modified: 2017-01-02 00:19 UTC (History)
2 users (show)

Fixed In Version: awscli-1.11.28-2.fc25 awscli-1.11.28-2.fc24 awscli-1.11.28-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-27 05:18:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Diego 2016-12-13 13:35:42 UTC
Description of problem:
awscli package seems to require python3-PyYAML, but it isn't a runtime dependency.

Version-Release number of selected component (if applicable):
awscli-1.11.24-1.fc25.noarch

How reproducible:
Always

Steps to Reproduce:
1. 'dnf install awscli'
2. 'aws configure' fails
$ aws configure
Traceback (most recent call last):
  File "/usr/bin/aws", line 27, in <module>
    sys.exit(main())
  File "/usr/bin/aws", line 23, in main
    return awscli.clidriver.main()
  File "/usr/lib/python3.5/site-packages/awscli/clidriver.py", line 53, in main
    driver = create_clidriver()
  File "/usr/lib/python3.5/site-packages/awscli/clidriver.py", line 62, in create_clidriver
    event_hooks=emitter)
  File "/usr/lib/python3.5/site-packages/awscli/plugin.py", line 44, in load_plugins
    modules = _import_plugins(plugin_mapping)
  File "/usr/lib/python3.5/site-packages/awscli/plugin.py", line 61, in _import_plugins
    module = __import__(path, fromlist=[module])
  File "/usr/lib/python3.5/site-packages/awscli/handlers.py", line 27, in <module>
    from awscli.customizations.cloudformation import initialize as cloudformation_init
  File "/usr/lib/python3.5/site-packages/awscli/customizations/cloudformation/__init__.py", line 13, in <module>
    from awscli.customizations.cloudformation.package import PackageCommand
  File "/usr/lib/python3.5/site-packages/awscli/customizations/cloudformation/package.py", line 21, in <module>
    from awscli.customizations.cloudformation.artifact_exporter import Template
  File "/usr/lib/python3.5/site-packages/awscli/customizations/cloudformation/artifact_exporter.py", line 25, in <module>
    from awscli.customizations.cloudformation.yamlhelper import yaml_dump, \
  File "/usr/lib/python3.5/site-packages/awscli/customizations/cloudformation/yamlhelper.py", line 14, in <module>
    import yaml
ImportError: No module named 'yaml'
3. 'dnf install python3-PyYAML'
4. 'aws configure' succeeds

Actual results:
aws configure crashes because of missing dependency

Expected results:
aws configure works without complaining out of the box

Comment 1 Fedora Update System 2016-12-13 20:28:20 UTC
awscli-1.11.28-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfcef83b6b

Comment 2 Fedora Update System 2016-12-13 20:28:26 UTC
awscli-1.11.28-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca1b7c7836

Comment 3 Fedora Update System 2016-12-13 20:28:30 UTC
awscli-1.11.28-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-eb8432856e

Comment 4 Fedora Update System 2016-12-13 20:28:35 UTC
awscli-1.11.28-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cad3dd7c2f

Comment 5 Fedora Update System 2016-12-15 02:28:20 UTC
awscli-1.11.28-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cad3dd7c2f

Comment 6 Fedora Update System 2016-12-15 02:49:55 UTC
awscli-1.11.28-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-eb8432856e

Comment 7 Fedora Update System 2016-12-15 05:03:08 UTC
awscli-1.11.28-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca1b7c7836

Comment 8 Fedora Update System 2016-12-15 05:06:32 UTC
awscli-1.11.28-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfcef83b6b

Comment 9 Fedora Update System 2016-12-27 05:18:33 UTC
awscli-1.11.28-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-12-27 10:48:56 UTC
awscli-1.11.28-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-12-27 15:48:02 UTC
awscli-1.11.28-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-01-02 00:19:08 UTC
awscli-1.11.28-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.