Bug 1404382 - Error pop up comes up on the first user login to KDE session
Summary: Error pop up comes up on the first user login to KDE session
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-settings
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1420851 1479818
TreeView+ depends on / blocked
 
Reported: 2016-12-13 17:16 UTC by Deepu K S
Modified: 2018-10-26 07:58 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 11:33:59 UTC


Attachments (Terms of Use)
KDE session at user login (80.17 KB, image/png)
2016-12-13 17:24 UTC, Deepu K S
no flags Details
KDE in VNC session at user login (163.47 KB, image/png)
2016-12-13 17:25 UTC, Deepu K S
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0717 None None None 2018-04-10 11:35 UTC

Description Deepu K S 2016-12-13 17:16:13 UTC
Description of problem:
An error pop-up window with below message is seen on the first time user logins to his KDE session.
"Unable to save bookmarks in /home/<new_user>/.local/share/user-places.xbel. Reported errror was: Insufficient permissions in target directory.. This error message will only be shown once. The cause of the error needs to be fixed as quickly as possible which is most likely a full hard drive."

Subsequent logins doesn't seem to exhibit this error.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.3
kdelibs-4.14.8-5.el7_2.x86_64
kde-settings-19-23.5.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Set the system default for the Graphical environment to KDE
# cat /etc/sysconfig/desktop 
DESKTOP="KDE"
DISPLAYMANAGER="KDE"

2. Create a new user from a terminal.
# useradd newuser
# passwd newuser

3. Try login as this user from GDM login screen.


The same happens with fresh VNC session for this user(as expected).

1. Set the system default for the Graphical environment to KDE
# cat /etc/sysconfig/desktop 
DESKTOP="KDE"
DISPLAYMANAGER="KDE"

2. Create a new user from a terminal. eg: by ssh from another host.
# useradd newuser
# passwd newuser

Do not log into graphical console.

3. Start a VNC server for this user.
$ vncserver :1

4. Connect with a vncviewer to this vncserver. It should be the first time user login to GUI.

Actual results:
Two error window [Error - Plasma Desktop Shell] and [Error - Run Command Interface] pops up showing.
"Unable to save bookmarks in /home/<new_user>/.local/share/user-places.xbel. Reported errror was: Insufficient permissions in target directory.. This error message will only be shown once. The cause of the error needs to be fixed as quickly as possible which is most likely a full hard drive."

Expected results:
No pop up windows showing errors.

Additional info:
It appears that the error is shown because '~/.local/share/' is not present on system and KDE at startup is trying to modify user-places.xbel

Creating the folders at user-login seems to fix this.

Comment 1 Deepu K S 2016-12-13 17:24 UTC
Created attachment 1231287 [details]
KDE session at user login

Comment 2 Deepu K S 2016-12-13 17:25 UTC
Created attachment 1231288 [details]
KDE in VNC session at user login

Comment 5 Jan Grulich 2017-09-13 08:57:34 UTC
Fixed in kde-settings-19-23.7.el7.

Comment 11 errata-xmlrpc 2018-04-10 11:33:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717


Note You need to log in before you can comment on or make changes to this bug.