Bug 1404551 - Lower version of packages subscription-manager, python-rhsm found in RHGS3.2 RHEL6 ISO.
Summary: Lower version of packages subscription-manager, python-rhsm found in RHGS3.2...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: releng
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sreenath G
QA Contact: Byreddy
URL:
Whiteboard:
Depends On:
Blocks: 1351528
TreeView+ depends on / blocked
 
Reported: 2016-12-14 05:46 UTC by Byreddy
Modified: 2017-03-23 05:11 UTC (History)
6 users (show)

Fixed In Version: RHGSS-3.2.0-RHEL-6-20170109.n.0-RHGSS-x86_64-dvd1.iso
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 05:11:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0484 normal SHIPPED_LIVE Moderate: Red Hat Gluster Storage 3.2.0 security, bug fix, and enhancement update 2017-03-23 09:06:37 UTC

Description Byreddy 2016-12-14 05:46:12 UTC
Description of problem:
=======================
Lower version of packages subscription-manager, python-rhsm, ql2400-firmware and ql2500-firmware found in RHGS3.2 RHEL6 ISO.

Pkg versions present in the ISO:
============================
subscription-manager-1.14.10-1.el6.x86_64
python-rhsm-1.14.3-1.el6.x86_64
ql2400-firmware-7.03.00-1.el6.noarch
ql2500-firmware-7.03.00-1.el6.noarch



Pkg versions present in the Live:
=================================

python-rhsm                                       x86_64                              1.16.6-1.el6                                   rhel-x86_64-server-6                              118 k
 ql2400-firmware                                   noarch                              7.03.00-1.el6_5                                rhel-x86_64-server-6                               94 k
 ql2500-firmware                                   noarch                              7.03.00-1.el6_5                                rhel-x86_64-server-6                              118 k
 subscription-manager                              x86_64                              1.16.8-8.el6                                   rhel-x86_64-server-6                              881 k


Version-Release number of selected component (if applicable):
=============================================================
Latest available RHGS3.2 RHEL6 ISO ( i will provide the ISO link in the next comment )


How reproducible:


Steps to Reproduce:
===================
1. Install the ISO
2. Register to satellite live and add the rhgs channel
3. Do yum update // You will see the updates getting for the packages mentioned in the title.

Actual results:
===============
Lower version of packages  subscription-manager, python-rhsm, ql2400-firmware and ql2500-firmware found in RHGS3.2 RHEL6 ISO.

Expected results:
=================
ISO should carry the package versions equal to or higher than live

Additional info:

Comment 4 Sreenath G 2016-12-14 17:03:05 UTC
Hi,

       Below are the build version of 4 packages used in latest nightly ISO RHGSS-3.2.0-RHEL-6-20161207.n.0-RHGSS.

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
subscription-manager-1.14.10-1.el6        RHEL-6.7              wpoteat
python-rhsm-1.14.3-1.el6                  RHEL-6.7              wpoteat
ql2400-firmware-7.03.00-1.el6             RHEL-6.6              kmcmarti
ql2500-firmware-7.03.00-1.el6             RHEL-6.6              kmcmarti


Please note that this is correct and taken based on latest released packages via Errata. The corresponding ET links are given below from which we can find out the latest released package builds to production.

https://errata.devel.redhat.com/package/show/subscription-manager
https://errata.devel.redhat.com/package/show/python-rhsm
https://errata.devel.redhat.com/package/show/ql2400-firmware
https://errata.devel.redhat.com/package/show/ql2500-firmware

Comment 5 RHEL Program Management 2016-12-14 17:12:45 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 6 Byreddy 2017-01-06 07:07:43 UTC
I am reopening this bz based on below details


ERRATA details of Latest version of packages subscription-manager, ql2500-firmware, ql2400-firmware and python-rhsm, these packages are present in Live

subscription-manager  - https://errata.devel.redhat.com/advisory/22057/builds

ql2500-firmware  -  https://errata.devel.redhat.com/advisory/17799/builds

ql2400-firmware  - https://errata.devel.redhat.com/advisory/17798/builds

python-rhsm   - https://errata.devel.redhat.com/advisory/22057/builds

I am seeing lower version of these packages in RHGS 3.2.0 iso, ISO should not carry the lower version packages when higher version packages available in Live ( Customer portal )

Comment 8 Sreenath G 2017-01-06 08:06:04 UTC
(In reply to Byreddy from comment #6)
> I am reopening this bz based on below details
> 
> 
> ERRATA details of Latest version of packages subscription-manager,
> ql2500-firmware, ql2400-firmware and python-rhsm, these packages are present
> in Live
> 
> subscription-manager  - https://errata.devel.redhat.com/advisory/22057/builds

The above Errata ET#22057 is not shipped yet and is in "QE" state. So as per ET#19945 [1], the latest shipped build for subscription-manager is subscription-manager-1.14.10-1.el6

> 
> ql2500-firmware  -  https://errata.devel.redhat.com/advisory/17799/builds

ql2500-firmware-7.03.00-1.el6 >  ql2500-firmware-7.03.00-1.el6_5 (which is RHEL-6.5-z)

> 
> ql2400-firmware  - https://errata.devel.redhat.com/advisory/17798/builds

ql2400-firmware-7.03.00-1.el6 >  ql2400-firmware-7.03.00-1.el6_5 (which is RHEL-6.5-z)
> 
> python-rhsm   - https://errata.devel.redhat.com/advisory/22057/builds

The above Errata ET#22057 is not shipped yet and is in "QE" state. So as per ET#19945 [1], the latest shipped build for python-rhsm is python-rhsm-1.14.3-1.el6

> 
> I am seeing lower version of these packages in RHGS 3.2.0 iso, ISO should
> not carry the lower version packages when higher version packages available
> in Live ( Customer portal )

[1] https://errata.devel.redhat.com/advisory/19945/builds

Comment 9 Byreddy 2017-01-06 09:19:15 UTC
History of ET#22057 says, this ET was shipped to Live on May 10, 2016.

so i am proposing to Fix the  subscription-manager  and python-rhsm issue.


AND

packages ql2500-firmware-7.03.00-1.el6_5 &  ql2400-firmware-7.03.00-1.el6_5 are there in RHEL main channel ( rhel-x86_64-server-6 )

So i am proposing this as well to fix.

Comment 10 Sreenath G 2017-01-06 11:33:03 UTC
(In reply to Byreddy from comment #9)
> History of ET#22057 says, this ET was shipped to Live on May 10, 2016.
> 
> so i am proposing to Fix the  subscription-manager  and python-rhsm issue.

The RHEL Errata#22057 was shipped, but reverted back later. After that, these package builds are not there in RHEL-6.8 and its only in RHEL-6.8-candidate which we don't subscribe to. So I am checking with RHEL team on when it will be moved to RHEL-6.8.
> 
> 
> AND
> 
> packages ql2500-firmware-7.03.00-1.el6_5 &  ql2400-firmware-7.03.00-1.el6_5
> are there in RHEL main channel ( rhel-x86_64-server-6 )
Here the qn is regarding the latest version. When querying RHEL, ql2500-firmware-7.03.00-1.el6 and ql2400-firmware-7.03.00-1.el6 are being shown as the latest versions. If we have to carry explicitly the 6_5 builds, then it will have to be tagged to rhgs-3.2 tag explicitly.

> 
> So i am proposing this as well to fix.

Comment 12 Sreenath G 2017-01-09 06:47:28 UTC
Regarding subscription-manager-1.16.8-8.el6 and python-rhsm-1.16.6-1.el6, RHEL has shipped ET#22057 and its available now in RHEL-6.8.

But ql2400-firmware-7.03.00-1.el6  and ql2500-firmware-7.03.00-1.el6 are the latest available builds from RHEL-6-latest-released. Also inside RHEL-6.8 RC compose [1], these packages are available.

 So if ql2400-firmware-7.03.00-1.el6_5  and ql2500-firmware-7.03.00-1.el6_5 has to be taken, then it needed to be explicitly tagged to rhgs-3.2-rhel-6-compose. 

[1] http://download-node-02.eng.bos.redhat.com/released/RHEL-6/6.8/Server/x86_64/os/Packages/

Comment 16 Byreddy 2017-01-20 10:21:50 UTC
Found correct version of packages subscription-manager, python-rhsm in the iso provided in comment 15

[root@~]# rpm -qa |grep subscription-manager
subscription-manager-1.16.8-8.el6.x86_64
[root@ ~]# 
[root@ ~]# rpm -qa |grep python-rhsm
python-rhsm-1.16.6-1.el6.x86_64
[root@ ~]# 


moving to verified state.

Comment 20 errata-xmlrpc 2017-03-23 05:11:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0484.html


Note You need to log in before you can comment on or make changes to this bug.