Bug 14046 - vi: Home and End keys in vt220
vi: Home and End keys in vt220
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-15 14:57 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-01 16:30:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-07-15 14:57:14 EDT
I telnet into a beta3 with vt220:
Home and End keys invert the case of the characters instead of going to 
the beginning and end of line. This is true for vi (vim-minimal) and vim 
(vim-enhanced), for both normal and insert mode.

They are ok at the console (could only try vim-minimal at the console 
though).

RedHat6.1 was ok.

This bug is very similar to #9963.
Comment 1 giulioo 2000-07-16 12:22:09 EDT
Some more problems:

DELETE:
TERM=linux: ok
TERM=vt220: does not work (neither in normal nor in insert mode)

BACKSPACE:
TERM=linux: ok in insert mode; just move the cursor left in normal mode (does 
not delete the char on the left of the cursor)
TERM=vt220: the same of TERM=linux.
Comment 2 Bernhard Rosenkraenzer 2000-08-03 09:35:30 EDT
Can't reproduce it with the current version.
Comment 3 giulioo 2000-08-04 09:18:53 EDT
Ok, maybe my VT emulator has some weird key mappings itself that make things go 
wrong (it works with 6.1, though).
Just for the record, I solved with:

map! ^[[1~ <home>
map! ^[[4~ <end>
map! ^[[3~ <del>
map ^[[1~ <home>
map ^[[4~ <end>
map ^[[3~ <del>



Note You need to log in before you can comment on or make changes to this bug.