Bug 140469 - Subpixel font smoothing worse on FC3.
Subpixel font smoothing worse on FC3.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 18:25 EST by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-05 20:22:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FC2 and FC3 subpixel smoothing comparison (22.89 KB, image/png)
2004-11-22 18:29 EST, Carlos Rodrigues
no flags Details

  None (edit)
Description Carlos Rodrigues 2004-11-22 18:25:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
On FC3 subpixel font smoothing looks much worse than on FC2 (actually,
on FC2 it looks nice).

I have the exact same configuration (in gnome font preferences):

"Subpixel smoothing (LCDs)"

Clicking on details also shows the same settings:

Smoothing: "Subpixel (LCDs)"
Hinting: "Full"
Subpixel order: "RGB"

On FC2, fonts look thin and well defined with these settings, but on
FC3 they look all weird with shades of blue, yellow and red.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.N/A
    

Additional info:
Comment 1 Carlos Rodrigues 2004-11-22 18:29:23 EST
Created attachment 107258 [details]
FC2 and FC3 subpixel smoothing comparison

Take a close look at the "sample text" and the menu text.

Actuall there is another problem there, on FC3 the text on the title bar is a
bit above the correct position. This doesn't happen with this theme only, but
I'm not sure who to blame, X or Metacity.
Comment 2 Carlos Rodrigues 2004-11-22 18:30:29 EST
BTW, this may seem like nitpicking, but on my TFT its the difference
between beautiful text (on FC2) and ugly text (FC3).
Comment 4 Owen Taylor 2004-11-22 23:32:57 EST
Reassigning to FreeType since it has nothing to do with X.

It's probably just changes in the FreeType hinting algorithm,
unfortunately, what improves display for one font at one
size, with one set of display options, may hurt somewhere
else. There isn't necessarily much we can do about that.

it could *conceivably* be a bug in gnome-settings-daemon,
or Pango, or Xft, in getting the right options to FreeType.
Comment 5 Carlos Rodrigues 2004-11-23 07:08:00 EST
From my perspective it's worse with every single font, at every single
size I've tried.

I will try to mess around with the font options in gnome, but on gdm I
see the same thing, since I've set:

Xft.hintstyle: hintfull
Xft.hinting: true
Xft.rgba: rgb

in /etc/X11/Xresources

I guess this could be an area where some finetuning options could be
nice. These options could be accessible only through resources or
gconf (one could someday make a wizard to help the user adjust it to
his liking, like Microsoft has for ClearType - well, in this case
ClearType just sucks, with every setting...).
Comment 6 Carlos Rodrigues 2004-11-23 07:14:04 EST
Hmmm, I guess only the "sample text" is noticeably worse on my
screenshots (and I just seen them on a CRT, which seems to disguise
the problem a bit), because the other text is against a gray
background. But I can assure you that on some apps, some text apperars
all colorful... :)
Comment 7 Alex Butcher 2004-11-24 19:09:48 EST
Taking a CVS snapshot of freetype2 and building with the bytecode
interpreter enabled is an improvement on the freetype 2.1.9 packages
included in FC3, IMHO.
Comment 8 Carlos Rodrigues 2004-11-28 21:32:51 EST
Problem gone. I had a ".font.conf" file on my home dir. I deleted it
and everything's fine now. I don't know where the hell that came from
though...
Comment 9 Carlos Rodrigues 2004-12-05 20:22:24 EST
It came from KDE Control Center... Annoying...

Note You need to log in before you can comment on or make changes to this bug.