Bug 14048 - Option -depth is broken in GNU find 4.1
Summary: Option -depth is broken in GNU find 4.1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: findutils   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-15 19:53 UTC by David A. Madore
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-15 19:54:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trivial patch that solves the bug (683 bytes, patch)
2000-07-15 19:54 UTC, David A. Madore
no flags Details | Diff

Description David A. Madore 2000-07-15 19:53:08 UTC
The -depth option is completely broken in GNU find 4.1

Here is a minimal example that will illustrate the bug: run

mkdir /tmp/foo ;
echo Blah > /tmp/foo/bar ;
find /tmp/foo -depth -empty

and the program will respond

find: /tmp/foo: Not a directory

this is evidently bogus.

I have submitted a bug-report to the FSF about this, but since the latest
version of findutils dates from 1994, it is rather dubious that anyone will
ever look into it.

I have written a (trivial) patch of my own that will correct the problem:
it is available at

ftp://quatramaran.ens.fr/pub/madore/misc/findutils-depthbug/findutils-4.1-depthbug.patch

furthermore, there is a source and (Intel) binary RPM that includes this fix:

ftp://quatramaran.ens.fr/pub/madore/misc/findutils-depthbug/findutils-4.1-34.1.src.rpm
ftp://quatramaran.ens.fr/pub/madore/misc/findutils-depthbug/findutils-4.1-34.1.i386.rpm

Comment 1 David A. Madore 2000-07-15 19:54:58 UTC
Created attachment 1167 [details]
Trivial patch that solves the bug

Comment 2 Preston Brown 2000-08-30 19:57:35 UTC
fixed for 7.0.


Note You need to log in before you can comment on or make changes to this bug.