Bug 140499 - Server hangs on reboot after install with SCSI & software RAID.
Server hangs on reboot after install with SCSI & software RAID.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 23:10 EST by Kent Ho
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 17:28:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kent Ho 2004-11-22 23:10:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
Grub doesn't install MBR on to both software RAID1 disks during install.

Version-Release number of selected component (if applicable):
grub-0.95-3

How reproducible:
Always

Steps to Reproduce:
I did a custom install with software RAID with 2 SCSI disks.

/dev/sda1  <->  /dev/sdb1  RAID1 (4G)
/dev/sda2 swap  /dev/sdb2  swap   
/dev/sda3  <->  /dev/sdb3  RAID1 (4G+)

Installs as normal.  After installation completes, I rebooted the
server and hangs after BIOS scans.

Summary
-------
1. Custom install with Software RAID1 running on SCSI "/".
2. Reboot after install completes
3. Server hangs immediately after BIOS scans.

Actual Results:  I rebooted the servers after fresh install and hangs
after BIOS scan.  Sometimes it displays a blank screen, sometime a
flashings cursor at top left and once it displayed "GRUB" and hangs.

Expected Results:  I should see a nice grub GUI boot menu and boot up
the machine.

Additional info:

I tried on 2 different machine setups.

config 1)
DUAL P3-500Mhz
Intel L440GX+ Serverboard onboard Adaptec aic7896 controller
2 * 9G SEAGATE ST39204LC
512Mb RAM.

config 2)
P3-500
Intel SE440BX2 desktop board
Adaptec 2940 SCSI controller
2 * 9G SEAGATE ST39204LC
256MB RAM

Both have the same problem.  I got round the problem by updating the
MBR in rescue mode.

http://www.fedoraforum.org/forum/showthread.php?t=26912
Comment 1 Yusuf Goolamabbas 2004-11-24 00:40:40 EST
I am seeing the same behaviour installing on 2 120GB maxtor IDE
ATA-133 disks. I can't seem to get the boot screen with the workaround
suggested with the fedoraforum.org pages

Kent, Can you pls change the summary to remove SCSI
Comment 2 Kai 'wusel' Siering 2005-08-11 06:51:00 EDT
Just as a side note, similar happend to my when installing FC4 (booted from
rescue CD and did install from DVD image on spare partition, due to lack of
DVD drive in the system) onto sda and sdb in SW-RAID1 mode attached to the
Symbios HBA on an HP'ed ASUS CUR-DLS. I had to do a rescue boot and install
grub onto the MBR of sda manually.

# more /proc/mdstat 
Personalities : [raid1] 
md1 : active raid1 sdb1[1] sda1[0]
      264960 blocks [2/2] [UU]
      
md0 : active raid1 sdb2[1] sda2[0]
      3148672 blocks [2/2] [UU]

# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/md0              3.0G  1.7G  1.2G  59% /
/dev/md1              251M   33M  206M  14% /boot
/dev/shm              442M     0  442M   0% /dev/shm

# fdisk -l
[...]
Disk /dev/sda: 36.9 GB, 36951490560 bytes
255 heads, 63 sectors/track, 4492 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          33      265041   fd  Linux raid autodetect
/dev/sda2              34         425     3148740   fd  Linux raid autodetect
/dev/sda3             426         556     1052257+  82  Linux swap / Solaris

Disk /dev/sdb: 36.9 GB, 36951490560 bytes
255 heads, 63 sectors/track, 4492 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          33      265041   fd  Linux raid autodetect
/dev/sdb2              34         425     3148740   fd  Linux raid autodetect
/dev/sdb3             426         556     1052257+  82  Linux swap / Solaris
[...]

Note You need to log in before you can comment on or make changes to this bug.