Bug 140500 - linux-2.6.9-1.6_FC2] compile error
linux-2.6.9-1.6_FC2] compile error
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 23:54 EST by Darin May
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 01:39:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darin May 2004-11-22 23:54:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Error after a "make all" near end of compile run:

[root@localhost linux-2.6.9-1.6_FC2]# make all
...
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
mm/built-in.o(.text+0x13956): In function `rw_vm':
: undefined reference to `kmap_atomic_pte'
mm/built-in.o(.text+0x13b98): In function `str_vm':
: undefined reference to `kmap_atomic_pte'
make: *** [.tmp_vmlinux1] Error 1
[root@localhost linux-2.6.9-1.6_FC2]# 

Version-Release number of selected component (if applicable):
linux-2.6.9-1.6_FC2]

How reproducible:
Always

Steps to Reproduce:
1. make mrproper
2. make xconfig
3. make all
    

Actual Results:  see above

Expected Results:  compile ok

Additional info:
Comment 1 Dave Jones 2004-11-23 00:15:19 EST

*** This bug has been marked as a duplicate of 126342 ***
Comment 2 Darin May 2004-11-23 18:44:36 EST
I have narrowed this down so that it's a usefull report:

Simply use the -686 default config and go into the Processor Features
page in xconfig and disable high memory support.
Comment 3 Dave Jones 2004-11-25 01:39:29 EST

*** This bug has been marked as a duplicate of 126342 ***
Comment 4 Darin May 2004-11-25 03:02:00 EST
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of 126342 ***

Pardon me for confusing bugzilla as a bug reporting tool.

I've located a bug, generated a simple test case, and shoved into a corner.

What is the method for reporting kernel compile bugs?  it's not as though I have
an esoteric case, but a specific, detailed report.  

Are we to assume that kernel development is immune from bug reports?

Note You need to log in before you can comment on or make changes to this bug.