Bug 140504 - openoffice in el_GR.UTF-8 shows blank or _ menu entries
openoffice in el_GR.UTF-8 shows blank or _ menu entries
Status: CLOSED DUPLICATE of bug 170218
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 01:17 EST by Ariel T. Glenn
Modified: 2014-03-16 22:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-30 09:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ariel T. Glenn 2004-11-23 01:17:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; el-GR; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
So, I field this against xorg fonts, but really, this is a request to
include utf-8 fonts with greek character support.  Otherwise,
Openoffice is unusable in that locale because the menu entries display
as totally blank with a few underscores here and there as teasers... 
even if I wanted to type docs in English,  I couldn't really navigate
around the app except with the icons on the toolbar :-(

My workaround was to include the FreeFont package:

    export CVS_RSH=ssh
    cvs -z3 -d:ext:anoncvs@savannah.nongnu.org:/cvsroot/freefont co
freefont

(The savvanah download area has been down for quite some time.)
This includes the three fonts FreeSans, FreeSerif, and FreeMono.  I
recommend excluding FreeMono, as it does not have the correct spacing
for use in gnome terminal, among other apps.

These fonts are in sfd format; they require fontforge (used to be
pfaedit) to convert them to ttf.  See fontforge.sourceforge.net.

After converting them, I added the directory I put ttf files in to the
beginning of the catalogue in /etc/X11/fs/config and to my
/etc/fonts/local.conf, restarted font server and X, and openoffice
worked fine, with the menu now readable and with freefonts showing up
in the list of fonts available for text use for typing as well.

Obviously you'll want to put them in the system-wide font config, not
local.conf.

These fonts are not perfect, but they are better than the alternative:
no fonts that work!

Thanks.

How reproducible:
Always

Steps to Reproduce:
1.Install FC3 outa the box
2.Set system locale as el_GR.UTF-8
3. start oowriter and look at blank menu entries.
Comment 1 Mike A. Harris 2004-11-23 04:32:00 EST
The only fonts that are included in X.Org X11, are the fonts that
X.Org supplies in the upstream X.Org X11 releases.  We do not
add fonts to X.Org directly, although we do ship additional fonts
as part of the OS distribution itself outside of X.Org packaging.

Reassigning to distribution component for consideration for future
OS releases.  If you have knowledge of additional Greek fonts that
meet the criteria you'd like to have included in the distribution
by default, which are under open source friendly license, or which
allow royalty free redistribution including in commercial products,
please update the bug report to recommend specific fonts to us
for review along with those at the URL you already provided.

Thanks for your request.
Comment 2 Bill Nottingham 2005-03-02 17:14:35 EST
In order to add a font to the distribution, we need more information;
see:

https://listman.redhat.com/archives/rhl-devel-list/2003-August/msg00154.html

Comment 3 John Thacker 2006-04-30 09:55:25 EDT
No response from reporter to request for information.

Note that the dejavu-fonts available in Fedora Extras add Greek
coverage.  There's a large discussion over at bug 170218 about
moving dejavu-fonts to Core to add, among other things, Greek
support.  Marking as duplicate since the real bug here is Greek
support.

*** This bug has been marked as a duplicate of 170218 ***

Note You need to log in before you can comment on or make changes to this bug.