This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 140506 - empty non-ide dvd and cd devices do not respond
empty non-ide dvd and cd devices do not respond
Status: CLOSED DUPLICATE of bug 134822
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On: 134822
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 02:06 EST by John Hedges
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 12:10:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Hedges 2004-11-23 02:06:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I have several dvd devices. some scsi and some firewire.
with no media in the devices:
[root@nemow ~]# cdrecord -scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) *
        0,1,0     1) '' '' ' NON CCS Disk
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) '' '' ' NON CCS Disk
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
scsibus3:
        3,0,0   300) '' '' ' NON CCS Disk
        3,1,0   301) *
        3,2,0   302) *
        3,3,0   303) *
        3,4,0   304) *
        3,5,0   305) *
        3,6,0   306) *
        3,7,0   307) *
scsibus4:
        4,0,0   400) '���'
'���' '���' Removable
unknown device type 0x1f
        4,1,0   401) *
        4,2,0   402) *
        4,3,0   403) *
        4,4,0   404) *
        4,5,0   405) *
        4,6,0   406) *
        4,7,0   407) *
[root@nemow ~]#

Placing media in each device even blank media works:
[root@nemow ~]# cdrecord -scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) *
        0,1,0     1) 'MATSHITA' 'DVD-RAM LF-D521 ' 'A116' Removable CD-ROM
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) 'MATSHITA' 'DVD-RAM LF-D200 ' 'A150' Removable CD-ROM
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
scsibus3:
        3,0,0   300) 'SONY    ' 'DVD RW DRU-700A ' 'VY06' Removable CD-ROM
        3,1,0   301) *
        3,2,0   302) *
        3,3,0   303) *
        3,4,0   304) *
        3,5,0   305) *
        3,6,0   306) *
        3,7,0   307) *
scsibus4:
        4,0,0   400) 'MATSHITA' 'DVD-RAM SW-9572 ' 'F100' Removable CD-ROM
        4,1,0   401) *
        4,2,0   402) *
        4,3,0   403) *
        4,4,0   404) *
        4,5,0   405) *
        4,6,0   406) *
        4,7,0   407) *
[root@nemow ~]#

Attempting to "eject /dev/scd0" only opens the drawer if there is
media in it. When running k3b media can not be verified, because after
the drawer is opened the device will not respond to the close command.
Similarly you can not make multiple copies. k3b like cdrecord can only
detect devices that have media installed. Scsi removable media may
also be affected??

I have to admit udev is my best guess. I have no idea why this
happens, but I have observed it on two systems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install on a system with a scsi or firewire cd/rom/rw or dvd/rom/rw
2.With no media in the /dev/scd0 device close it's drawer. 
3.issue the command eject /dev/scd0 to open the drawer.

    

Actual Results:  The drawer will not open.

Expected Results:  Previous version of Redhat and fedora the device's
drawer would open.

Additional info: If you place media in the device and close it and
issue the command it does open.
Comment 1 Harald Hoyer 2004-11-23 08:05:05 EST
see bug #134822
Comment 2 Harald Hoyer 2004-12-07 12:10:55 EST

*** This bug has been marked as a duplicate of 134822 ***

Note You need to log in before you can comment on or make changes to this bug.