Bug 1405190 - python3-flake8 doesn't follow the executable naming guidelines
Summary: python3-flake8 doesn't follow the executable naming guidelines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-flake8
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-15 20:31 UTC by Randy Barlow
Modified: 2018-04-11 14:26 UTC (History)
4 users (show)

Fixed In Version: python-flake8-2.5.5-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-28 20:20:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Randy Barlow 2016-12-15 20:31:56 UTC
Description of problem:
I installed python3-flake8 and I expected to find /usr/bin/flake8, or /usr/bin/flake8-3{,.5}, but instead it seems to be installed as /usr/bin/python3-flake8. The Python packaging guidelines say that executables should either:

0) be owned by python2- or python3- (usually python3- should be preferred), in which case python3-flake8 could provide /usr/bin/flake8, or

1) be named /usr/bin/flake8 (provided by python2-), /usr/bin/flake8-2, /usr/bin/flake8-2.7, /usr/bin/flake8-3, and /usr/bin/flake8-3.5.


Version-Release number of selected component (if applicable):
python3-flake8-2.5.5-2.fc25.noarch


How reproducible:
Every time.


Steps to Reproduce:
1. Install python3-flake8


Actual results:
/usr/bin/python3-flake8 exists.


Expected results:
/usr/bin/flake8 or both /usr/bin/flake8-3 and /usr/bin/flake8-3.5 should exist, and python3-flake8 should not exist.


Additional info:
I recommend fixing this only in Rawhide, since it is a backwards incompatible change. Alternatively, you could fix it in F24-25 and keep python3-flake8 in them as a compatibility, but if you do that I recommend not installing the compatibility binary in Rawhide.


[0] https://fedoraproject.org/wiki/Packaging:Python#Naming

Comment 1 Fedora Update System 2016-12-20 10:20:14 UTC
python-flake8-2.5.5-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7dc3e1e1a3

Comment 2 Fedora Update System 2016-12-20 19:21:17 UTC
python-flake8-2.5.5-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7dc3e1e1a3

Comment 3 Fedora Update System 2016-12-28 20:20:53 UTC
python-flake8-2.5.5-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.