Bug 1405321 - mdadm will not detect drives connected to Intel Raipd Storage RAID on Intel cm236 chipset with NVME SSD connected
Summary: mdadm will not detect drives connected to Intel Raipd Storage RAID on Intel c...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-16 08:31 UTC by Sebastian
Modified: 2019-01-09 12:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-16 09:13:21 UTC


Attachments (Terms of Use)
Output of dmesg (76.46 KB, text/plain)
2016-12-16 08:31 UTC, Sebastian
no flags Details

Description Sebastian 2016-12-16 08:31:29 UTC
Created attachment 1232458 [details]
Output of dmesg

Description of problem:
mdadm will not detect drives connected to Intel Raipd Storage RAID n UEFI on Intel cm236 chipset on Asus G752vy, propably missing support for cm236 chipset.

Version-Release number of selected component (if applicable):
Fedora 25 Live


How reproducible:
Install Fedora 25 live iso on usb in UEFI mode, run it in UEFI mode.

Steps to Reproduce:
1.Open terminal.
2.su [enter]
3.mdadm --detail-platform

Actual results:
Platform : Intel(R) Rapid Storage Technology
        Version : 14.8.0.2377
    RAID Levels :
    Chunk Sizes : 4k 8k 16k 32k 64k 128k
    2TB volumes : supported
      2TB disks : supported
      Max Disks : 7
    Max Volumes : 2 per array, 4 per controller
 I/O Controller : /sys/devices/pci0000:00/0000:00:17.0 (SATA)
          Port0 : - no device attached -
          Port1 : - no device attached -


Expected results:

It should list attached disk to the IRST raid, but there is no disks listed.


Additional info:
Problems with ata driver from dmesg:
[    9.206647] ata2.00: qc timeout (cmd 0xa1)
[    9.206655] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[    9.206670] ata1.00: qc timeout (cmd 0xef)
[    9.206677] ata1.00: failed to enable AA (error_mask=0x4)
[    9.517319] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    9.517343] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    9.520588] ata1.00: ATA-8: HGST HTS721010A9E630, JB0OA3J0, max UDMA/133
[    9.520592] ata1.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32)
[   19.958671] ata2.00: qc timeout (cmd 0xa1)
[   19.958679] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   19.958682] ata2: limiting SATA link speed to 1.5 Gbps
[   20.269167] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   25.590680] ata1.00: qc timeout (cmd 0x27)
[   25.590687] ata1.00: failed to read native max address (err_mask=0x4)
[   25.590689] ata1.00: HPA support seems broken, skipping HPA handling
[   25.590691] ata1.00: revalidation failed (errno=-5)
[   25.590741] ata1: limiting SATA link speed to 3.0 Gbps
[   25.590743] ata1.00: limiting speed to UDMA/133:PIO3
[   25.901171] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   40.950718] ata1.00: qc timeout (cmd 0xef)
[   40.950724] ata1.00: failed to set xfermode (err_mask=0x4)
[   40.950777] ata1.00: disabled
[   40.950790] ata1: hard resetting link
[   41.261221] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   41.261230] ata1: EH complete
[   50.678741] ata2.00: qc timeout (cmd 0xa1)
[   50.678749] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   50.989249] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)

There are  Samsung 950Pro and HGST HTS721010A9E630 connected to IRST Raid in JBOD mode, the Samsung 950Pro does not get detected!

Same error is litsed here:
https://bbs.archlinux.org/viewtopic.php?id=212198

Comment 1 Sebastian 2016-12-16 09:13:21 UTC
Seems disconnecting physicaly Samsung 950Pro will remedy the problem and drived do get detected now.

Output of mdadm --detail-platform after removing Sammy 950Pro from system:
Platform : Intel(R) Rapid Storage Technology
        Version : 14.8.0.2377
    RAID Levels :
    Chunk Sizes : 4k 8k 16k 32k 64k 128k
    2TB volumes : supported
      2TB disks : supported
      Max Disks : 7
    Max Volumes : 2 per array, 4 per controller
 I/O Controller : /sys/devices/pci0000:00/0000:00:17.0 (SATA)
          Port1 : - non-disk device (TSSTcorp CDDVDW SU-228GB) -
          Port0 : /dev/sda (JR10004M09SMLF)


Propable BIOS Bug due to broken NVME driver in BIOS?


Note You need to log in before you can comment on or make changes to this bug.